lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-05-2010, 06:20 PM   #1
Not Yet Wild
 
JimXtreme's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Cajun Country, La.
Posts: 50
Default '96 TXT Ignition system troubleshooting

I need help with Ignition system troubleshooting on m y '96 TXT with the 295cc engine.

It with fire the plug momentarily when I first hit the pedal and then nothing...
JimXtreme is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-06-2010, 05:16 AM   #2
Not Yet Wild
E-Z-GO
 
Join Date: Nov 2008
Location: South Western Pa.
Posts: 15
Default Re: '96 TXT Ignition system troubleshooting

It is the Ignitor
spled77 is offline   Reply With Quote
Unread 08-06-2010, 08:13 AM   #3
Not Yet Wild
 
JimXtreme's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Cajun Country, La.
Posts: 50
Default Re: '96 TXT Ignition system troubleshooting

Quote:
Originally Posted by spled77 View Post
It is the Ignitor
Where is the ignitor located?
JimXtreme is offline   Reply With Quote
Unread 08-06-2010, 03:58 PM   #4
Doin' the Wild Thang
 
ez go go's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Greenville, AL
Posts: 1,063
Default Re: '96 TXT Ignition system troubleshooting

On my 2000 it is under a black plastic shroud under the seat on the left front.. It is a black plastic module with 4 wires coming out of it. Draw a schematic before removal so you put it back on properly. A crossed connection could damage it and they are not cheap.. A word of advice, see if you can find a loaner and try it. The pulsar and the coil are tied in with this device and could be the problem... I just hate to see you buy an ignitor and not need it. The tech section has a thread with ohm values on the pulsar and you can probably find some info. on coil testing with a thread search.. Hope this helps and maybe saves some money.. Good Luck
ez go go is offline   Reply With Quote
Unread 08-06-2010, 04:43 PM   #5
Gone Wild
 
chardonite's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: Chardon Ohio
Posts: 257
Default Re: '96 TXT Ignition system troubleshooting

For some reason when the ignitor go bad it acts just like your describing. A couple of sparks then nothing. Good Luck.........
chardonite is offline   Reply With Quote
Unread 08-09-2010, 07:37 AM   #6
Not Yet Wild
 
JimXtreme's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Cajun Country, La.
Posts: 50
Default Re: '96 TXT Ignition system troubleshooting

Quote:
Originally Posted by ez go go View Post
On my 2000 it is under a black plastic shroud under the seat on the left front.. It is a black plastic module with 4 wires coming out of it. Draw a schematic before removal so you put it back on properly. A crossed connection could damage it and they are not cheap.. A word of advice, see if you can find a loaner and try it. The pulsar and the coil are tied in with this device and could be the problem... I just hate to see you buy an ignitor and not need it. The tech section has a thread with ohm values on the pulsar and you can probably find some info. on coil testing with a thread search.. Hope this helps and maybe saves some money.. Good Luck
The one with the solenoid, etc.?
JimXtreme is offline   Reply With Quote
Unread 08-09-2010, 07:50 AM   #7
Not Yet Wild
 
JimXtreme's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Cajun Country, La.
Posts: 50
Default Re: '96 TXT Ignition system troubleshooting

I'm guessing this is it?
Attached Images
File Type: jpg ignitor.JPG (6.5 KB, 2 views)
JimXtreme is offline   Reply With Quote
Unread 08-09-2010, 09:19 AM   #8
Doin' the Wild Thang
 
ez go go's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Greenville, AL
Posts: 1,063
Default Re: '96 TXT Ignition system troubleshooting

Quote:
Originally Posted by JimXtreme View Post
I'm guessing this is it?
Yup!! That's the ignitor...
ez go go is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Harley Davidson point ignition system Gas Harley Davidson
troubleshooting Electric golf carts
Non-DCS Troubleshooting help Electric EZGO
95 EZ- GO troubleshooting Electric EZGO
batt / chg system troubleshooting Electric Club Car


All times are GMT -5. The time now is 05:22 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.