lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-15-2010, 06:01 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Jan 2008
Location: Bowling green Ky
Posts: 5
Default 2007 Ezgo Starting Problem (Gas)

I have a 2007 TXT gas ezgo. This problem only happens occasionally,when the cart has come to a stop. I press on the gas pedal to start again, it is like the key has been turned to off, it will not do anything. So far I have been able to push the cart 3 to 4 feet by hand in forward or reverse and it will start again.Any help will be appreciated.
glama is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-15-2010, 06:08 PM   #2
Gone Wild
 
StoveBolt's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, Michigan "Home of M.I.S."
Posts: 2,614
Default Re: 2007 Ezgo Starting Problem (Gas)

Loose wire connection some where?
StoveBolt is offline   Reply With Quote
Unread 06-15-2012, 10:01 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2009
Location: The Villages, FL
Posts: 15
Default Re: 2007 Ezgo Starting Problem (Gas)

Quote:
Originally Posted by glama View Post
I have a 2007 TXT gas ezgo. This problem only happens occasionally,when the cart has come to a stop. I press on the gas pedal to start again, it is like the key has been turned to off, it will not do anything. So far I have been able to push the cart 3 to 4 feet by hand in forward or reverse and it will start again.Any help will be appreciated.
I have the same problem with my 2008 RXV. EZGO sent me a smaller pulley for the starter/generator. They seem to think that the starter, which is the same one used on older, smaller engines, did not have enough torque to rotate the engine when it is hot and stops at TDC. The new pulley made the problem less frequent, but it still happens occasionally. I also replaced the battery cables with heavier ones. Again this helped, but so far nothing has permanently cured the problem. I can always get it going again by moving the shift lever to neutral, push the cart with my foot and then shift it into forward while it's moving. This causes the engine crankshaft to move off Top Dead Center. It will then start ok.

Any advice on how to fix this problem would be appreciated.
bsain is offline   Reply With Quote
Unread 07-06-2012, 11:52 PM   #4
Not Yet Wild
 
Join Date: Apr 2012
Posts: 46
Default Re: 2007 Ezgo Starting Problem (Gas)

I have the same problem with a 95 medalist cart,ran great for 9 holes then i stopped at my car and went to go again and nothin.If i spin the generator belt(new) a little and then hit pedal it takes off.Maybe a sign of a bad generator or brush's...
4strokejunkie is offline   Reply With Quote
Unread 07-08-2012, 11:08 AM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2009
Location: The Villages, FL
Posts: 15
Default Re: 2007 Ezgo Starting Problem (Gas) Update

Quote:
Originally Posted by bsain View Post
I have the same problem with my 2008 RXV. EZGO sent me a smaller pulley for the starter/generator. They seem to think that the starter, which is the same one used on older, smaller engines, did not have enough torque to rotate the engine when it is hot and stops at TDC. The new pulley made the problem less frequent, but it still happens occasionally. I also replaced the battery cables with heavier ones. Again this helped, but so far nothing has permanently cured the problem. I can always get it going again by moving the shift lever to neutral, push the cart with my foot and then shift it into forward while it's moving. This causes the engine crankshaft to move off Top Dead Center. It will then start ok.

Any advice on how to fix this problem would be appreciated.
Update:
I talked to a tech at our local EZ-GO dealership and he says the problem is most likely due to a weak solenoid. He says he's seen this problem on a few RXVs. When the solenoid gets hot due to heat buildup in the engine compartment after long runs it doesn't make good contact and isn't supplying enough voltage to the starter to crank the engine. This makes sense to me because whenever I've had a problem with the starter not cranking the engine it would always start if I waited 30 seconds or so before trying the starter again.
I took his advice and replaced the solenoid and so far I've not had any more starter problems.
bsain is offline   Reply With Quote
Unread 07-09-2012, 02:24 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2012
Location: Knoxville, TN
Posts: 5
Default Re: 2007 Ezgo Starting Problem (Gas)

I have a similiar problem on my 99 txt. Solenoid didn't fix it for me.

We have figured out that turning the key off and back on will usually get it to fire again. I'm wondering if it's the connection in the gas pedal switch or the key switch itself.

Cart starts instantly once it begins to turn over. Any other thoughts?
pintailwizard is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
problem with 81 ezgo starting. (sometimes) Gas EZGO
1998 EZGO-Gas starting problem Gas EZGO
2001 Gas Ezgo Starting Problem Gas EZGO
problem with starting 91 ezgo gas Gas EZGO
EZGO Starting Problem Gas EZGO


All times are GMT -5. The time now is 04:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.