lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-26-2010, 11:15 AM   #11
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: New Jersey
Posts: 24
Default Re: Ezgo won`t stay running

ok well I took the exhaust off and still running about the same running with the open headed figured that I will cook the exhaust anyway. Now when I got it back in the shop I tried to restart and it won`t start just cranked pulled the plug and it`s was really fouled but gave it a quick clean and fired right up. took it for another ride and same thing got it back in the shop and wouldn`t start again pulled the plug and cleaned fired right up. Did notice that when cranking the fuel filter was being sucked dry is that normal or should that be filled at all times. Does that mean I have a fuel issue??Maybe a air leak inside the tank??
pineypowerwpww is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-26-2010, 11:21 AM   #12
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,189
Default Re: Ezgo won`t stay running

The fuel filter should not be full but also it should not be "sucked dry" I think that I would remove the line from the carburetor and crank the engine. Do you see a healthy pulsing jet of fuel?
This instantly fouling plug raises a red flag. Is your air filter clogged up?
Dave Box is offline   Reply With Quote
Unread 12-26-2010, 11:27 AM   #13
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: New Jersey
Posts: 24
Default Re: Ezgo won`t stay running

filter is new and got a good stream of gas coming out kind of lost
pineypowerwpww is offline   Reply With Quote
Unread 12-26-2010, 07:43 PM   #14
Gone Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Decatur,IL
Posts: 553
Default Re: Ezgo won`t stay running

Is your oil injector still hooked up? Sounds like it is putting too much oil to the mix.
rokcrlr is offline   Reply With Quote
Unread 12-30-2010, 11:02 AM   #15
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: New Jersey
Posts: 24
Default Re: Ezgo won`t stay running

Nope no oiler on it Mixing 50:1.
pineypowerwpww is offline   Reply With Quote
Unread 12-30-2010, 11:22 AM   #16
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2010
Location: Minneapolis, Kansas
Posts: 66
Default Re: Ezgo won`t stay running

I don't much at all about the 2 stokes, but Dave Box talked about a mixture of 128:1 on the 2pg. You might PM him and see if it is the same on your cart. Just trying to help!
98 EZGO is offline   Reply With Quote
Unread 12-30-2010, 11:47 AM   #17
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,189
Default Re: Ezgo won`t stay running

Yes the 2PG should be run at 128:1. I don't know what the 3PG is but 50:1 sounds very rich to me and if the plug is instantly fouling up .......
I think I would be tempted to make a batch of 128:1 and see how the cart runs. I think if it was my cart I would also want to know what the compression is as well. Maybe you need new rings.
Dave Box is offline   Reply With Quote
Unread 12-30-2010, 12:01 PM   #18
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,985
Default Re: Ezgo won`t stay running

You say you flipped the reeds, maybe recheck them?
DOOmsman is offline   Reply With Quote
Unread 12-30-2010, 12:28 PM   #19
no clue
 
madoc1's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: spicewood, texas
Posts: 3,309
Default Re: Ezgo won`t stay running

3pg is also 128/1 after the initial tank according to ezgo tag.
Attached Images
File Type: jpg DSC00883.jpg (118.3 KB, 8 views)
madoc1 is offline   Reply With Quote
Unread 12-31-2010, 12:12 PM   #20
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: New Jersey
Posts: 24
Default Re: Ezgo won`t stay running

ok will try 128:1. compersion is around 160-170.
pineypowerwpww is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G16 won't stay running Gas Yamaha
90 Marathon Will not stay running Gas EZGO
88 Gas 2PG wont stay running Gas EZGO
won't stay running Gas EZGO
motor won't stay running Gas Yamaha


All times are GMT -5. The time now is 04:12 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.