lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-10-2011, 02:26 PM   #1
Not Yet Wild
 
Join Date: Jun 2011
Posts: 8
Default 79 Gas EZGO runs but won't move

Hi everyone
I'm trying to get a 1979 gas ezgo running. Everything's great, starts, engine runs... but it won't move forward or backward. There is a long cable that looks like it came out of the engine, but I don't have any idea what that is. Do you have any insight on this? Thanks for any info you can give me. I don't have a manual for it, so I'm kinda stuck.
nv_gladiators is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-10-2011, 02:35 PM   #2
LET IT RUN
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 10,716
Default Re: 79 Gas EZGO runs but won't move

Welcome to BGW


Sounds like you could have a striped brake hub/drum, you need someone to help you check it, someone in the cart with foot on the brake, crank the motor, put it in gear, and push the gas JUST A LITTLE. and the other person needs to see if the castle nut in the middle of the rear wheels, that holds the brake hub on is spinning and the cart is not moving
rib33024 is offline   Reply With Quote
Old 06-10-2011, 02:39 PM   #3
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,824
Default Re: 79 Gas EZGO runs but won't move

Right Rib and also it may just be cranking, the long cable is a question/

Nv is it revving up or just spinning slow?
DOOmsman is offline   Reply With Quote
Old 06-10-2011, 02:42 PM   #4
Not Yet Wild
 
Join Date: Jun 2011
Posts: 8
Default Re: 79 Gas EZGO runs but won't move

The cable comes off the back of the accelerator linkage, and that cable is broken. The nut is not moving by the way. The belt on the drive train is not moving.
nv_gladiators is offline   Reply With Quote
Old 06-10-2011, 03:02 PM   #5
Not Yet Wild
 
Join Date: Jun 2011
Posts: 8
Default Re: 79 Gas EZGO runs but won't move

does anyone have a diagram or schematic of this thing? Thanks again for any help.
nv_gladiators is offline   Reply With Quote
Old 06-10-2011, 03:36 PM   #6
Not Yet Wild
 
Join Date: Jun 2011
Posts: 8
Default Re: 79 Gas EZGO runs but won't move

Doom, it does not rev, but goes slow
nv_gladiators is offline   Reply With Quote
Old 06-10-2011, 09:21 PM   #7
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,141
Default Re: 79 Gas EZGO runs but won't move

When you press on the pedal does the link on the top of the carburetor move? If so the broken cable is the governor and you can forget that for now.

If the belt is not turning it sounds like the engine is cranking but not actually firing. Does the engine run faster the harder you press the pedal? I suspect not.

Can you post some pictures maybe a video?

Dave
Dave Box is offline   Reply With Quote
Old 06-11-2011, 11:58 AM   #8
Not Yet Wild
 
Join Date: Jun 2011
Posts: 8
Default Re: 79 Gas EZGO runs but won't move

When u press the gas it runs faster
nv_gladiators is offline   Reply With Quote
Old 06-11-2011, 02:38 PM   #9
Not Yet Wild
 
Join Date: Jun 2011
Posts: 8
Default Re: 79 Gas EZGO runs but won't move

http://m.youtube.com/?client=mv-goog...?v=pZ3j460YqMs

Hi fellas, I linked a video of the engine, as I put the cart in forward. Thanks for any help u can give.
nv_gladiators is offline   Reply With Quote
Old 06-12-2011, 10:26 AM   #10
Gone Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Decatur,IL
Posts: 553
Default Re: 79 Gas EZGO runs but won't move

Link didn't work for me
rokcrlr is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Runs great wont move!!! Gas Club Car
Runs/starts - won't move - forward or reverse Gas Club Car
EZ GO Workhorse runs, but does not move Gas EZGO
EZGO J402 motor runs but cart won't move Electric EZGO
97 Ezgo Motor runs but will not move Gas EZGO


All times are GMT -5. The time now is 07:38 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.