lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-31-2011, 01:06 PM   #1
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Engine Runs But Won't Move

I've inherited an old gas EZ Go golf cart along with a cottage. My father bought it used from a local golf course 20 years ago so I'd guess that it's '70s or '80s manufacture. I'll work on that part. Yesterday wife and sister take it down the road and return on foot. After towing it back I found that it starts and runs, but will not move on forward of reverse. The drive belt is whole, but seems loose, and does not engage. It has been loosing power over the years, but was still usable. I realize that I'm not going to get a fix here, but can anyone get me started in the right direction? Thanks.
BillScott is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-31-2011, 08:16 PM   #2
Gone Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Decatur,IL
Posts: 553
Default Re: Engine Runs But Won't Move

The belt is probably worn out for starter, Put the rear axle on jack stands to see if the clutchs are working correctly. The front should close up at the same time as the rear opens up to change gear ratios. If you have to put a new belt on, get the shorter performance belt as it will give the old girl alittle more power and pickup. See here:http://www.mfgsupply.com/m/c/HP3004.html. Then get back to us.
rokcrlr is offline   Reply With Quote
Old 07-31-2011, 10:04 PM   #3
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: Engine Runs But Won't Move

That makes sense. I'm at home now, two hours away the the cart, but I'll bring some jackstands or blocks the next time I go up. I think that I need some general knowledge about carts before getting too involved in this project. I have a decent basic mechanical knowledge, mostly automotive related, as a tire dealer....though not a tech. Is there an exploded parts diagram somewhere, even a general one, since the year is still unknown? I'm a bit unsure what is supposed to be happening in the rear end of this thing. Thanks for your help.
BillScott is offline   Reply With Quote
Old 08-01-2011, 10:31 AM   #4
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 1,903
Default Re: Engine Runs But Won't Move

there should be a plate on the floorboards, generally on the passenger side of the "hump" under your cupholders - if it's an older, OLDER cart though it could be anywhere as they had a few locations - you need to find it and post the 2 numbers listed and we can nail down the year for you...

In the interim, though - if the cart has points ignition it would be a pre-1981, the easiest way to find out is to look at the passenger side of the engine casing (down low) - if you have a single wire coming out it's pre-81, if you have 2 wires (red and blue) then it's a pulsar-style system or 81-up which is GOOD as parts are quite more readily available ...

We need to ascertain the year or at least a bit closer to help you out accurately, however the tech section at the top of this thread is a good place to find links to your diagrams, etc once we have the general "Era" of manufacture nailed down
BrewCityMusic is offline   Reply With Quote
Old 08-01-2011, 11:03 AM   #5
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: Engine Runs But Won't Move

Thanks, I'll check that as well. I did talk to one of my techs here at work who has some snow mobile experience. He explained the basics of the clutch system to me. What I'm still confused about is the plastic covered dome on the driver's side, in front of the rear differential. There is an articulated metal tab in front of this that is connected to a cable running up to the carb. It was frozen up, with the tab touching the nose of this dome. I freed it but the cable id loose on the carb side. I don't see any way for this to operate. Is this "dome" a magnetic actuator of some sort? If so, does it control the halves of the clutch? I'm not trying to jump ahead of the basic diagnostic procedure, just understand how this is supposed to work. I'll keep you all informed. Thanks for the help.
BillScott is offline   Reply With Quote
Old 08-01-2011, 11:28 AM   #6
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,144
Default Re: Engine Runs But Won't Move

What you are describing the the speed governor. As the cart goes faster that clutch expands and pushes on the lever. This in turn pulls on a cable that forces the throttle to close. It is a safety feature that stops drunken golfers from exceeding 12 mph. Many folks (including myself) have simply removed the whole assembly and worked out that the cart will go slower if they back off the throttle.

Dave
Dave Box is offline   Reply With Quote
Old 08-01-2011, 11:31 AM   #7
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 1,903
Default Re: Engine Runs But Won't Move

that's your governor, and the way it works is simple: as your driven clutch opens up under high speed, the dome (and the wear button on the top of it) move towards that lever, eventually pushing it which in turn (through the cable) retards the throttle a bit to prevent over-revving ...

Most people just disconnect it from the carb and run without it, I chose to restore mine as I have a few friends who also drive my cart and rather than trusting them to keep the engine in a safe RPM range, I'd make SURE it happened - it's entirely up to you if you want to hook it back up
BrewCityMusic is offline   Reply With Quote
Old 08-01-2011, 11:34 AM   #8
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 1,903
Default Re: Engine Runs But Won't Move

aaaand BAM - superceeded by Dave as I type slowly, hahahahaha

And Dave, as always I have to state that if these weren't designed for fun while drinking, WHY do they have drinkholders ?!?!?!

(especially mine - seats 2, 4 drink positions .... Karma, pure and simple. Who am I to question?)
BrewCityMusic is offline   Reply With Quote
Old 08-01-2011, 11:47 AM   #9
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: Engine Runs But Won't Move

I now begin to understand. Thanks for explaining that....both of you.
BillScott is offline   Reply With Quote
Old 08-01-2011, 04:57 PM   #10
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: Engine Runs But Won't Move

I'm trying to think through the belt solution to this problem. Shouldn't I see the clutch begin to spin as the engine picks up rpms? Since it doesn't move, what good does a smaller belt do? I'm think that if this is true, I have a clutch or engine speed/power problem. Again, I understand that we need the vehicle year to get the correct parts to solve the problem.....just trying to understand the mechanics of this thing so that I can possibly save a five hour round trip.
BillScott is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
79 Gas EZGO runs but won't move Gas EZGO
Runs great wont move!!! Gas Club Car
Runs/starts - won't move - forward or reverse Gas Club Car
EZ GO Workhorse runs, but does not move Gas EZGO
97 Ezgo Motor runs but will not move Gas EZGO


All times are GMT -5. The time now is 06:04 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.