lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-25-2011, 08:06 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2010
Location: Georgia
Posts: 3
Default 89 2 stroke with intermittent running problems

im looking for some advice as i have not been able to figure this thing out on my own. i have a 1989 ezgo marathon with the 2 stroke gas motor, i believe to be a 2pg.

my problems only seem to happen after riding the cart for maybe fifteen minutes. the cart starts great, and runs great but after 15 minutes it just starts to die. i have done a few things trying to diagnose it myself with no luck. the only solution i have found is to pull the choke out when it starts to die. it seems to get it going again but then you have to push it back in to let it continue running. if you do this 5 times it straightens out for another 15 minutes or so. i will say that it doesnt seem to do this when you hold it wide open.

this is what i have done to try and fix the cart and nothing has seemed to even help it.
1. replaced muffler with new one
2. cleaned carb
3. upgraded ignition system to the hei system
4. had dealer replace faulty micro switch on gas pedal
5. had mechanic replace head gasket as motor was rebuilt before i bought it and head was leaking a little air
6. replaced and checked every electrical connector on the cart looking for a bad connection.

any help would be greatly appreciated as i havent had any luck with this thing! thanks!
dedward4 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-26-2011, 08:37 AM   #2
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,189
Default Re: 89 2 stroke with intermittent running problems

I don't see you changing the fuel filter and a partially blocked filter would give these symptoms.

Dave
Dave Box is offline   Reply With Quote
Unread 09-27-2011, 09:39 PM   #3
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: 89 2 stroke with intermittent running problems

Hey ded,

Welcome here. Also, if the cart has sat for some time, this could be a symptom of some sort of small blockage somewhere in the carb (caused by the loosening of crud), or higher up in the fuel system (as Dave suggested). Choking refills the bowl, and it's obviously taking about 15 mins for the carb to drain the bowl empty.
ScooterMcTavish is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Why my stock 89 2 stroke running lean? Gas EZGO
EH29c 4-stroke rattle when not running? Gas EZGO
2001 Elec EZ Go TXT Intermittent Running Electric EZGO
2 Stroke running engine temperature Gas EZGO
1984 2 stroke running rough Gas EZGO


All times are GMT -5. The time now is 09:05 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.