lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-20-2012, 09:29 AM   #21
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2011
Location: Indiana
Posts: 41
Default

Good idea with the loctite, I'll use that.

I woke up this morning thinking I probably should see if I can get it to start back up again to be 100% sure its the seals. Couldn't get it to even rumble, kinda worries me, but I guess either way I've gotta pull the engine.

Now about pulling the engine, is there anything I should know before taking this engine out? Like do I take the starter off and where do I unbolt the starter? At the mounts or do I just take the starter off and things like that lol. I plan on marking the cables and bagging nuts and bolts.

uploadfromtaptalk1340201969485.jpg

That's how I got it from the previous owner... lol yeah its bad. Question, obviously I'll need a new cable and put a spring on there, is there a cheaper way of fixing the cable? Like just getting new cable and threading it through the original sheath? Has that been done? I just gotta watch my money right now. :(

uploadfromtaptalk1340202232051.jpg

This is her by the way lol. Day I got her, traded a 20ga shotgun and $150, pretty good deal I think.

Anyway, its been too hot for me to work on it, girlfriend has been taking my time from it, gotta take my mother in for back surgery today so its going to take me a bit to get to the cart, but I'm going to keep my thread updated and pictures posted. Probably do some step by step pictures so if anyone else likes picture guides as much as me can maybe get something back from my experience.

Sent from my VM670 using Tapatalk 2
CClark56 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-20-2012, 01:59 PM   #22
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 2,681
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

here's the order I did my engine in: fuel lines and intake - exhaust - wires - cables - belts - starter and bracket - pull engine ... Total front to back til engine is out took me about 20 minutes, might go smoother for you though as I had a tool box wipeout just before I started and was working with a mishmash pile of hand tool and sockets, etc :)
BrewCityMusic is offline   Reply With Quote
Unread 06-20-2012, 04:40 PM   #23
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 497
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

I didn't have to unhook my starter cables.I just took out the battery and the cables were long enough to let me lay it in the pocket where the battery goes.

This is a vid I made that shows a bit of it.Keep in mind there are three bolts that hold the engine to the cradle that appear to go into the head.Those were missing from mine when I got it so I didn't mention them in the vid.They're right across from the bolts at the base of the block though.If you look carefully you can see where they go in the video.I'll even put an annotation on there just for you.


So Brew, 20 minutes eh?Maybe we all ought to get together and have an engine swap challenge.
Heliarc is offline   Reply With Quote
Unread 06-21-2012, 01:18 AM   #24
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2011
Location: Indiana
Posts: 41
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

Thanks for the info, again! Okay so update, surprised that a buddy of mine came over and we were just talking, walked out to the garage and whatta ya know, we pulled the engine out, almost felt like an accident lol.

So here's what I found and other notes...

Once we got it out I notice when I turn the crank it makes almost like a sizzle sound, it's just a very, very, very little bit of oil going around the piston, from what I can tell. Which makes me feel like it has good compression, idk though. I know when I turn the crankshaft there's a lot of push back, like pressure, so I think that means good compression?

I noted a good amount of oil at the seal where the muffler pipe meets the motor.

I also noted play when I shook the crankshaft, I did not notice ANY play when it was in the cart, I don't know why I have play now but oh well. (So this means I need new barrings?)

I noticed what looked like a seal sticking out from between the head and the crankcase, it was as if the seal blew out the side? But you wouldn't be able to tell it, I couldn't get the smallest feeler gauge in the world between the head and the case, so I don't know about that.

Also, I took the muffler pipe off, the piston looks pretty good, the rings definitely look new to me, but I'm no expert. Starting to think someone did the top end of this engine recently but obviously couldn't get it to run.

I'll try and get some pictures soon, if anyone can answer a few of those questions that'd be great. Thanks everyone for helping me out on this, pretty awesome.
CClark56 is offline   Reply With Quote
Unread 06-21-2012, 10:04 AM   #25
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 497
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

Yea, you'll be needing bearings.If you just go and pop in the seals the crank moving around will wipe them out in minutes.Get your cylinder head off and the jug and take it to a shop with a press after you get your bearings and seals.

I could also feel the crank pushing back on me when turning the engine by hand, but I had about 20 thousandths worth of slop between my piston and cylinder wall.The only real way to tell is a compression tester.Or once you get the head off, check the gap in between the piston and cylinder with your feeler gauges.I believe it shouldn't be more than seven thousandths.

Oil at the bottom of the muffler pipe is at least indicative that it hasn't been run totally dry, so that's probably a good thing.

But so far, you're in the market for three crankshaft bearings, two crank seals, a cylinder to block gasket, and a head gasket.Once you know more you might be adding rings.I had to get an oversize piston and have my cylinder bored out.
Heliarc is offline   Reply With Quote
Unread 06-25-2012, 02:06 AM   #26
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2011
Location: Indiana
Posts: 41
Default

Okay, back again, not much else to report, life's busy right now but I really want to get this cart going. But I got out to the garage and took a few pics and a video for inspection.

Here's it finally out of the cart lol.
uploadfromtaptalk1340607565648.jpg

Now here's the gasket I was talking about, its just kinda sticking out.
uploadfromtaptalk1340607565648.jpg

Also, now that I noticed it. It seems there actually isn't any play on the crankshaft, I think I wasn't thinking at the time and was jiggling the crankshaft with my hands on the clutch, I think it was the clutch making it seem like I had play.

https://www.youtube.com/watch?v=bWYe6Myx4Uc

That's the piston, notice the air sound, not sure if you can hear it on the video. But yeah.

Sent from my VM670 using Tapatalk 2
Attached Images
File Type: jpg uploadfromtaptalk1340607619250.jpg (99.6 KB, 0 views)
CClark56 is offline   Reply With Quote
Unread 06-29-2012, 07:52 AM   #27
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2011
Location: Indiana
Posts: 41
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

Quote:
Originally Posted by Heliarc View Post
I didn't have to unhook my starter cables.I just took out the battery and the cables were long enough to let me lay it in the pocket where the battery goes.

This is a vid I made that shows a bit of it.Keep in mind there are three bolts that hold the engine to the cradle that appear to go into the head.Those were missing from mine when I got it so I didn't mention them in the vid.They're right across from the bolts at the base of the block though.If you look carefully you can see where they go in the video.I'll even put an annotation on there just for you.

Golf cart top end rebuild PT1 - YouTube

So Brew, 20 minutes eh?Maybe we all ought to get together and have an engine swap challenge.
I know it's a lil late to say, but I actually got to watch your vid all the way through with sound this time (been on my phone through most of this and it's a pain to watch videos) and I just wanted to say nice job on it, helped a lot.

Also bumping for some answers on my last questions with the video and gasket picture, even though I didn't attach it right lol.
CClark56 is offline   Reply With Quote
Unread 07-02-2012, 12:31 PM   #28
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 497
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

The video is set to private.And I do believe that gasket is your cylinder to block gasket.
Heliarc is offline   Reply With Quote
Unread 07-02-2012, 01:50 PM   #29
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2011
Location: Indiana
Posts: 41
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

Yeah that seems like the gasket it'd be. And no clue how that happened.

CClark56 is offline   Reply With Quote
Unread 07-03-2012, 11:27 PM   #30
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2011
Location: Indiana
Posts: 41
Default Re: 1987 EZ-GO cranks but doesn't run [please help, about to give up]

It's pissing me off, I can not find a dang 3/4" x 2" bolt to get the clutch off..
CClark56 is offline   Reply With Quote
Reply

Tags
carb, ezgo, fuel, not starting
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1 Problems: cranks, but will not run Gas Yamaha
cranks when you turn on the key Gas Club Car
93 Club Car cranks, fires once, then nothing Gas Club Car
can i swap cranks to fit clutchs Big Block Talk!
cranks fine Gas EZGO


All times are GMT -5. The time now is 05:07 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.