lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-28-2012, 09:12 PM   #1
Getting Wild
 
capthump1's Avatar
E-Z-GO
 
Join Date: May 2009
Location: (winter) Homosassa,Fl / (summer) Bayonne,N.J./ Port Jervis, N.Y.
Posts: 131
Default Early Marathon Problem

Just picked up an ealy 80's Marathon gasser, got it running. Previous ower had the starter wired wrong. I disconnected the oil injection system and removed it. Premix 128:1.Cart rans faorly well. The one problem I'm having is with the clutches. It has to rev pretty high before it starts to move and it kind of does it with a jerk. Primary clutch? Up on blocks everything looks ok, primary closes secondary opens. On the ground you have to rev it before it jumps into gear, both fwd & rev.And it seems like it should be going faster, but it I'm used to my Workhorse. Any ideas?
capthump1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-28-2012, 10:06 PM   #2
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hamlin,NY
Posts: 5,384
Default Re: Early Marathon Problem

Is the belt worn?A loose and Narrow belt will cause alot of problems,I'd start there if everything else looks ok.
pachanga90 is offline   Reply With Quote
Unread 08-29-2012, 09:16 AM   #3
Getting Wild
 
capthump1's Avatar
E-Z-GO
 
Join Date: May 2009
Location: (winter) Homosassa,Fl / (summer) Bayonne,N.J./ Port Jervis, N.Y.
Posts: 131
Default Re: Early Marathon Problem

Belt looks ok. Its just that you have to get the revs up before the clutch engages. Then bang, off you go, you can get whiplass on this cart.
capthump1 is offline   Reply With Quote
Unread 08-30-2012, 09:52 PM   #4
Gone Wild
 
1fast67's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: spokane,wa
Posts: 974
Default

A new belt is 1 3/16" wide and if your belt is below 1" it is most likely slipping cause it to grab hard. I would measure it to be sure. Im with pachanga on this one.

Sent from my LG-P999 using Tapatalk 2
1fast67 is offline   Reply With Quote
Unread 08-31-2012, 08:00 AM   #5
Getting Wild
 
capthump1's Avatar
E-Z-GO
 
Join Date: May 2009
Location: (winter) Homosassa,Fl / (summer) Bayonne,N.J./ Port Jervis, N.Y.
Posts: 131
Default Re: Early Marathon Problem

I'll break out the ruler but my calibrated eyeball says its about that.
capthump1 is offline   Reply With Quote
Unread 08-31-2012, 08:03 PM   #6
Gone Wild
 
1fast67's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: spokane,wa
Posts: 974
Default

I just thought of something else to check. Maybe try spraying some wd-40 on your secondary clutch where the spring is. There might be some dirt in there or the bushing is getting worn enough to where the sheaves are binding up. Food for thought.

Sent from my LG-P999 using Tapatalk 2
1fast67 is offline   Reply With Quote
Unread 08-31-2012, 08:21 PM   #7
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hamlin,NY
Posts: 5,384
Default Re: Early Marathon Problem

If its' taking off hard,thats either the belt is too narrow,too short(not the case here,revs alot on takeoff),or the Primary-Clutch spring is too stiff,or the clutch is binding.The secondary won't start to open till its' underway.
pachanga90 is offline   Reply With Quote
Unread 08-31-2012, 08:31 PM   #8
Gone Wild
 
1fast67's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: spokane,wa
Posts: 974
Default

Now that i think about it your right. My bad. It was just a thought.

Sent from my LG-P999 using Tapatalk 2
1fast67 is offline   Reply With Quote
Unread 09-10-2012, 11:17 AM   #9
Getting Wild
 
capthump1's Avatar
E-Z-GO
 
Join Date: May 2009
Location: (winter) Homosassa,Fl / (summer) Bayonne,N.J./ Port Jervis, N.Y.
Posts: 131
Default Re: Early Marathon Problem

Well I finally measured the belt it was 1 1/16, I orderd a new one. Will see if that does it. It seems the primary has to move abit before it grabs the belt, the extra 1/8" will definetly help.
capthump1 is offline   Reply With Quote
Unread 09-10-2012, 06:25 PM   #10
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hamlin,NY
Posts: 5,384
Default Re: Early Marathon Problem

If the belt is worn on its' width,its' also stretched in length,which will also cause your complaint.Keep us posted.
pachanga90 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Late 70's/early 80's Marathon Gasser Rear End Golf Carts and Parts
pot problem marathon Electric EZGO
Early 80s Marathon belt or clutch? Gas EZGO
Problem with 82 marathon Electric EZGO
early marathon parts Golf Carts and Parts


All times are GMT -5. The time now is 03:51 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.