lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-13-2012, 08:24 AM   #31
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: 88 ezgo 2 cycle flooding out runs fine on top end

What kind of belt do you have sassy? Is it 44 1/2 inches? I'm thinking its the carb, the belt or clutches???? The guy I bought from which is a friend of mine told me he thought it was the carb I just want to make absolutely sure before I just start buying stuff where is the best place to get a carb and/or a belt?
Dmontgomery is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-13-2012, 01:10 PM   #32
Gone Wild
 
sassycat's Avatar
E-Z-GO
 
Join Date: Sep 2012
Location: bikini state
Posts: 2,715
Default Re: 88 ezgo 2 cycle flooding out runs fine on top end

i only no i had the stock belt"you need a number off yours to tell" and the 1 inch shorter belt i have now will in no way let me push the cart at all unless i remove the belt,,or use the starter motor to move it.
mine sometimes wont go in reverse,like its a contact point thing or something,then if i go forward a few inches and shift into rev then it will catch..weird i no..
if your cart can be pushed w/out pressing the pedal id think it has a stock belt on it,,def not sure tho.
when you push start yours and drive it,it is running good the hole time?
and just wont start on its own from a dead stop?
sassycat is offline   Reply With Quote
Unread 11-13-2012, 03:06 PM   #33
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: 88 ezgo 2 cycle flooding out runs fine on top end

14153-G is the # on the belt, I'm thinking its the stock belt, the engine will start from a stop but it will not move without a little push!
Dmontgomery is offline   Reply With Quote
Unread 11-14-2012, 05:45 PM   #34
Gone Wild
E-Z-GO
 
Join Date: Nov 2012
Location: North Carolina
Posts: 161
Default Re: 88 ezgo 2 cycle flooding out runs fine on top end

ok I figured out that the low speed adjustment screw is supposed to be set 1 full turn out from lightly seated, the screw with the nut, it was set at 2 turns out! I turned it 1 out and tried it and it deffinatly seems to have helped, spinning the bald tires on it in wet grass..def better than trying to push with one leg lmao, then it got dark on us so me and the kids will mess with it more tmrw and see if it gets any better. gotta get this thing right so i can start upgrading..lol
Dmontgomery is offline   Reply With Quote
Unread 11-14-2012, 07:27 PM   #35
Gone Wild
 
sassycat's Avatar
E-Z-GO
 
Join Date: Sep 2012
Location: bikini state
Posts: 2,715
Default Re: 88 ezgo 2 cycle flooding out runs fine on top end

glad ya hopefully got it figured out..the kids are gonna want to drive it now lol..just got my daughter a car and she still wants to drive the cart all the time
sassycat is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
01' EZGO TXT Series w/no reverse(runs fine in FWD) Electric EZGO
Yam G9 runs fine but doesn't charge Gas Yamaha
Thanks to everyone here, cc 2002 ds runs fine now Electric Club Car
91 EZgo 36volt, starts off slow then runs fine? Electric EZGO
Runs fine but low power! Gas EZGO


All times are GMT -5. The time now is 01:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.