lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-22-2012, 01:34 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2012
Location: Circleville, oh
Posts: 3
Default Have to loosen muffler to get motor running

96 ezgo, have micro switch bypassed on gas pedal, it gets a little cold where I'm at so I hook a battery charger up and let motor idle for 15-20 minutes.Gotta use charger so battery don't die. Have tried adjusting throttle so generator gives enough juice to battery. It don't work,motor floods or battery done. Anyway,after engine gets warm it won't go unless I loosen muffler up to where gasket slides out. Only got 1 bolt in,tired of taking other bolt out. Frees up a hand too.Give some gas and the motor will go,but I gotta run it a minute before I put gasket back in.Then it'll run till the next day...rinse & repeat. I have taken muffler off and blew compressed air through it and it didn't seem to be clogged.Any troubleshooting tips would be much appreciated!
Merry Christmas,and a happy golf cart year!!!
GOMERSITH is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-22-2012, 06:31 AM   #2
Gone Wild
 
frodrummer's Avatar
E-Z-GO
 
Join Date: Sep 2012
Location: Savannah MO
Posts: 206
Default Re: Have to loosen muffler to get motor running

Although you can blow air through the muffler, I would still try BBQ'ing the muffler. You may have enough room in the muffler to allow air passage (and some exhaust for that matter) but it may not be enough for the engine to push out the exhaust as it should. I'd wager that you've got a lot of buildup in there that is gumming up the flow.
frodrummer is offline   Reply With Quote
Unread 12-22-2012, 09:48 AM   #3
Gone Wild
 
stretchman's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: temecula ca.
Posts: 197
Default Re: Have to loosen muffler to get motor running

I had a cart once that was backed into a mound of sand. It packed the pea shotter small pipe with it and wouldn't run. I think your problem is tight intake valves (low compression) pull spark plugs and see if you got at least 150psi. Also you can put the cart half way between fwd/rev (neutral) and rev-up cart till it warms up
stretchman is offline   Reply With Quote
Unread 12-22-2012, 10:34 AM   #4
I Refuse To Get Stuck!!!
 
pachanga90's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Hamlin,NY
Posts: 5,384
Default Re: Have to loosen muffler to get motor running

Check the Outlet on the muffler,if it's crushed,or bent it will restrict flow.If there is anything broken internally in the muffler that will also cause your problem(I've seen it on carts and cars/trucks,it will strangle power).Check the valve adjustments as well(doesn't hurt to check them occasionally anyway).Hope this helps.
pachanga90 is offline   Reply With Quote
Reply

Tags
motor, muffler, running
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
3PG motor,muffler,clutch for sale Golf Carts and Parts
3pg motor, muffler, and starter/generator Golf Carts and Parts
new motor now not running Electric Club Car
Motor running hot now Extreme DC!


All times are GMT -5. The time now is 08:11 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.