lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-06-2013, 10:05 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2013
Location: Wisconsin
Posts: 13
Default 90 marathon bad fuel pump?

Just picked up my 1990 marathon, I knew it needed some work getting into it. Cleaned the carb new belt and oil injection line, when I drive it or have it on a stand it will take awhile to pick up and move then will gain speed like crazy then bog back down. I've found that if I feather the choke while I drive it it seems to run decent. Bad fuel pump? Or am I missing something?
Ezgocruiser90 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-06-2013, 10:50 PM   #2
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: 90 marathon bad fuel pump?

You can check the pump easily by disconnecting the fuel line going to the carb, then turn over the motor and see if it is pumping fuel. Could be bad crank seals, or a float adjustment. If it starts good, likely the crank seals are ok. Another thing to check is the vent on the top of the gas tank. Make sure the vent is not plugged. Check the rubber carb boot for cracks.
1989Marathon is offline   Reply With Quote
Unread 04-07-2013, 11:48 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2013
Location: Wisconsin
Posts: 13
Default Re: 90 marathon bad fuel pump?

Checked the fuel pump, it seems to be good. I changed the fuel filter and ran the cart out of a gas can of good fuel. It still does the same thing where it bogs down and dies until you choke it but seems to be a little better. I checked the crank seals by spraying carb cleaner around it while it was running there was no change. Any ideas on what to do from here?
Ezgocruiser90 is offline   Reply With Quote
Unread 04-07-2013, 12:50 PM   #4
Gone Wild
 
icyveins's Avatar
Yamaha
 
Join Date: Mar 2013
Location: DORR MI
Posts: 226
Default Re: 90 marathon bad fuel pump?

air/fuel ratio ? has then been messed with or bumped?
icyveins is offline   Reply With Quote
Unread 04-07-2013, 02:36 PM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2010
Location: Plettenberg bay South Africa
Posts: 63
Default Re: 90 marathon bad fuel pump?

Had a similar problem when I got my cart took forever to figure it I out but the previous owner had put the incorrect plug in
New correct Plug and she ran like a dream
Might be worth checking
slainte is offline   Reply With Quote
Unread 04-07-2013, 03:13 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2013
Location: Wisconsin
Posts: 13
Default Re: 90 marathon bad fuel pump?

What plug should be in it? I know the guy i bought it from just changed the plug right before i bought it
Ezgocruiser90 is offline   Reply With Quote
Unread 04-07-2013, 06:12 PM   #7
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2013
Location: Wisconsin
Posts: 13
Default Re: 90 marathon bad fuel pump?

Changed the plug still no change
Ezgocruiser90 is offline   Reply With Quote
Unread 04-08-2013, 11:25 AM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2013
Location: Wisconsin
Posts: 13
Default Re: 90 marathon bad fuel pump?

If the oil-gas mixture was off would it cause this problem?
Ezgocruiser90 is offline   Reply With Quote
Unread 04-09-2013, 05:41 AM   #9
Gone Wild
 
frodrummer's Avatar
E-Z-GO
 
Join Date: Sep 2012
Location: Savannah MO
Posts: 207
Default Re: 90 marathon bad fuel pump?

The mixture shouldn't cause this issue. I'd take a close look at the carb. Tear it down and clean. While doing this, pay close attention to the needle/seat area, as well as the float. Float should be parallel with the bowl mounting surface. At the very minimum, you'll have a clean carb when you are done.
frodrummer is offline   Reply With Quote
Unread 04-11-2013, 10:59 AM   #10
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2013
Location: Wisconsin
Posts: 13
Default Re: 90 marathon bad fuel pump?

I'm tearing down the carb now for the 3rd time I'm kind of at a loss at what's going on here, anyone know of any aftermarket 4 stroke motors that will drop in and use the factory clutches? I'm gonna get away from 2 strokes if I swap motors I think.
Ezgocruiser90 is offline   Reply With Quote
Reply

Tags
bad fuel, low power, pump
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1988 Parcar Fuel pump Or no Fuel pump? Gas Columbia ParCar
1991 EZGO Marathon possible fuel pump issue? Gas EZGO
g1 new fuel pump still wont pump HELP Gas Yamaha
fuel pump not putting out fuel Gas EZGO
85 marathon fuel pump Gas EZGO


All times are GMT -5. The time now is 09:58 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.