lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-11-2013, 09:42 PM   #21
Not Yet Wild
 
Jharpo711's Avatar
 
Join Date: May 2013
Posts: 22
Default Re: 4X4 Ezgo transmission prob???

No luck yet!?!?
Jharpo711 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-12-2013, 08:25 PM   #22
Not Yet Wild
 
Jharpo711's Avatar
 
Join Date: May 2013
Posts: 22
Default Re: 4X4 Ezgo transmission prob???

Rusty I have not heard from you? Any luck with the part?
Jharpo711 is offline   Reply With Quote
Unread 06-12-2013, 10:37 PM   #23
Not Yet Wild
E-Z-GO
 
Join Date: May 2013
Location: Indiana
Posts: 38
Thumbs up Re: 4X4 Ezgo transmission prob???

Hi
I am new to this forum have not posted anything as of yet. I too have an ST 4x4 with transmission problems. I had googled for information and was refered to this forum on a few occasions. I don't know whether you have obtained a service parts manual or not, but you can go to eastcoastcarts.com and they offer a download for this manual. I have somewhat of a mechanical ability and I am not intimidated with any thing as long as I have a schematic to go along with it. I have mine tore down and am waiting for parts for the governor shaft inside as well as seals. I found that M&D Mower and Appliance of Highland, Ohio has an efficient search and price for EZGO parts. They are not cheap but I have found almost everyting I need there. I acquired my ST4x4 not knowing it was missing the front drive shaft which has added quite an expense to my fix up budget. I am also looking for a CVT Cover as mine is pretty well beat up. Hopefully someone will start parting these units out as stated in other threads, the parts are getting hard to find. I hope this information helps and feel fre to contact me if you need any more help.
Piddler is offline   Reply With Quote
Unread 06-12-2013, 10:52 PM   #24
Not Yet Wild
E-Z-GO
 
Join Date: May 2013
Location: Indiana
Posts: 38
Default Re: 4X4 Ezgo transmission prob???

Hi again
I reread your initial thread and question and realized I had not addressed a possible solution. I think you are going to have to pull the transmission out and open her up. To do this one of the first steps is to remove the CVT Cover and this would allow you to see if the belt is OK or not. If it is OK you will have to pull the clutches off, remove the CVT back plate, and then pull out the Transmission. Once you have it out split it open and see what is not right. My guess is the main drive gear or the chain is busted. Then you can search with the part numbers for availability. Again if I can be of further assistance don't hesitate to contact me.
Piddler is offline   Reply With Quote
Unread 06-12-2013, 11:13 PM   #25
Gone Wild
E-Z-GO
 
Join Date: Jul 2010
Location: s/w pa
Posts: 364
Default Re: 4X4 Ezgo transmission prob???

man im sorry if forgot to many irons in the fire! i will look in the am before work.
i will pm you my cell text me

rusty
rusty shackel is offline   Reply With Quote
Unread 10-04-2013, 02:42 PM   #26
Not Yet Wild
E-Z-GO
 
Join Date: Jan 2013
Location: Creatview Florida
Posts: 27
Default Re: 4X4 Ezgo transmission prob???

Hi guys i also have the 4x4 tranny very loud here are some pics of the inside oh ya i purchased the last set of gears for this tranny about 3 years ago im now installing.... if u need any info let me no. Check ebay for parts i counld not find any exept there. Ezgo does still carry bearings seals and drive chain for the tranny hope this helps
Attached Images
File Type: jpg 2013-10-02_16-17-49_694.jpg (129.8 KB, 0 views)
File Type: jpg 2013-10-02_16-18-04_974.jpg (107.6 KB, 0 views)
File Type: jpg 2013-10-02_16-18-33_464.jpg (174.4 KB, 0 views)
File Type: jpg 2013-10-02_16-19-01_544.jpg (138.5 KB, 0 views)
File Type: jpg 2013-10-02_16-18-55_20.jpg (122.9 KB, 0 views)
Carson624 is offline   Reply With Quote
Unread 10-08-2013, 08:53 PM   #27
Not Yet Wild
 
Jharpo711's Avatar
 
Join Date: May 2013
Posts: 22
Default Re: 4X4 Ezgo transmission prob???

The main gear is stripped. I have it broke down now. Part number 602842 main gear. Any one know where I can find one?? Thanks!!
Jharpo711 is offline   Reply With Quote
Unread 10-09-2013, 06:26 PM   #28
Not Yet Wild
E-Z-GO
 
Join Date: Jan 2013
Location: Creatview Florida
Posts: 27
Default Re: 4X4 Ezgo transmission prob???

Good luck talk to team ind. They might have specs so you could get some made. Mine were striped too i just happened to buy the last ones team had.
Carson624 is offline   Reply With Quote
Unread 10-13-2013, 09:52 PM   #29
Not Yet Wild
 
Jharpo711's Avatar
 
Join Date: May 2013
Posts: 22
Default Re: 4X4 Ezgo transmission prob???

I called them they don't have any parts. Sucks hopefully I can find one some where soon.
Jharpo711 is offline   Reply With Quote
Unread 10-14-2013, 12:39 PM   #30
Not Yet Wild
E-Z-GO
 
Join Date: May 2013
Location: Indiana
Posts: 38
Default Re: 4X4 Ezgo transmission prob???

Quote:
Originally Posted by Carson624 View Post
Hi guys i also have the 4x4 tranny very loud here are some pics of the inside oh ya i purchased the last set of gears for this tranny about 3 years ago im now installing.... if u need any info let me no. Check ebay for parts i counld not find any exept there. Ezgo does still carry bearings seals and drive chain for the tranny hope this helps
Hi Carson624
Are the pics you are showing of the new gears? Were the teeth stripped on the input shaft or on the main gear? What I am getting at that I too have an issue with a shrill sound coming from the trans. I had to rebuild the governor flyweights and support on the input haft as the inside bearing went bad and allowed the governor weights to be knocked off. When I had my trans. apart I had noticed that my teeth appeared very worn on the input shaft but none were missing. I do know that a local machine shop can replicate any gear and if I had the proper specs or something to refer to as the new part I would have one made. If you have not installed these parts would you be willing share this info with others? If so I will PM you so that we could make arrangements.

This would be of great help
Piddler
Piddler is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
wild ride (elc ezgo galf cart prob) Electric EZGO
91 Ezgo transmission problem Electric EZGO
need help with g8 prob. Gas Yamaha
Columbia par car 96 prob Gas Columbia ParCar


All times are GMT -5. The time now is 10:11 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.