lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-30-2007, 05:46 PM   #11
Gone Wild
 
Dero's Avatar
 
Join Date: Jan 2007
Posts: 731
Default

thats why muaythai is going to weld it shut with his laser eyes...cyclops style.
Dero is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-30-2007, 05:48 PM   #12
Peanut
 
mb523's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: Western Massachusetts
Posts: 655
Default

A test for the muffler...

Unbolt the header pipe from the muffler so that there is a good like 1/2" space between them and run it. If it runs better, then the muffler is plugged. I agree with dero, run her hot and let her smoke.
mb523 is offline   Reply With Quote
Unread 05-30-2007, 05:53 PM   #13
Gone Wild
 
Dero's Avatar
 
Join Date: Jan 2007
Posts: 731
Default

Quote:
Originally Posted by mb523
Unbolt the header pipe from the muffler so that there is a good like 1/2" space between them and run it.
I recommend ear plugs
Dero is offline   Reply With Quote
Unread 05-30-2007, 05:58 PM   #14
Peanut
 
mb523's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: Western Massachusetts
Posts: 655
Default

I second that motion... been there done that!! Moved my cart across yard with NO muffler AT ALL and NO SEAT..... ouchy
mb523 is offline   Reply With Quote
Unread 05-30-2007, 06:02 PM   #15
Gone Wild
 
Dero's Avatar
 
Join Date: Jan 2007
Posts: 731
Default

Same here
Dero is offline   Reply With Quote
Unread 05-30-2007, 06:03 PM   #16
Gone Wild
 
Join Date: Dec 2006
Location: ComplainAboutNoNo'sProfile-Ville
Posts: 4,995
Default

Even though it's running hot, you're still running more unburnt gas/oil through it. I would still try Dero and Mitch's idea. Then....GUT IT!
NO NO NO E-Z-GO! is offline   Reply With Quote
Unread 05-30-2007, 06:11 PM   #17
roady89
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by mb523
A test for the muffler...

Unbolt the header pipe from the muffler so that there is a good like 1/2" space between them and run it. If it runs better, then the muffler is plugged. I agree with dero, run her hot and let her smoke.
I did just that and it DID run better...thats why I was askin.
  Reply With Quote
Unread 06-09-2007, 02:30 PM   #18
Peanut
 
mb523's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: Western Massachusetts
Posts: 655
Default

Any luck gettin the EZ running any better?
mb523 is offline   Reply With Quote
Unread 06-09-2007, 02:39 PM   #19
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,936
Default

Sorta...I just loosend the exhaust pipe clamp and let it breate a little more. A little loud but it runs alot better. I'm either going to get a new muffler or gut the old one.
roady89 is offline   Reply With Quote
Unread 06-09-2007, 10:56 PM   #20
Gone Wild
 
Dero's Avatar
 
Join Date: Jan 2007
Posts: 731
Default Re: 91 ezgo engine performance?

Seriously try running it nonstop. It does the same thing as a muffler BBQ. I have head this from bob.
Dero is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 02:58 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.