lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-01-2013, 02:27 PM   #1
Not Yet Wild
Yamaha
 
Join Date: Oct 2012
Location: Michigan
Posts: 34
Default I have my marathon running but?

The inside of the muffler is loose and this thing seems very loud. The tail pipe off the muffler is gone so maybe it needs one. Also it seems to take quite a while to ramp up to speed and it seems slow next to my Yamaha G1. Both of these have fresh rebuilds. This is a 2pg engine. Any thoughts?
Thanks,
Don
dcolliau is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-17-2013, 09:38 PM   #2
Gone Wild
 
Join Date: May 2013
Posts: 320
Default Re: I have my marathon running but?

Mnay have told of BBQing the muffler on a good camp fire to burn out the build up of crudy oily junk. I may be doing this to mine as I took it off and the muffler feels a bit heavy for its size. If they get plugged up you get to much back pressure. Try running it without the muffler for a bit and see if you have an improved rev. I will be doing this real soon also.
redcloud is offline   Reply With Quote
Unread 07-18-2013, 11:30 AM   #3
Not Yet Wild
 
PartTime's Avatar
E-Z-GO
 
Join Date: May 2013
Location: S.C. Ark.
Posts: 72
Default Re: I have my marathon running but?

Diffently do not run very long with muffler off, as you can end up having other problems. Burnt valves, etc.. But sounds as though you need anew one, esp. if the pipe is broken off the btm. of exhaust. Just saying.
PartTime is offline   Reply With Quote
Unread 07-18-2013, 08:15 PM   #4
Gone Wild
 
Join Date: May 2013
Posts: 320
Default Re: I have my marathon running but?

Yes, do not run engine long without muffler. No valves in a 2 0r 3PG but still not a good idea.
One guy that I have seen on the forum did a spring mount at the header to muffler joint sim. to an auto type system. He had a very shaky muffler that blurred when running and was breaking pipes. After he installed the springs it smoothed. out he said.
Test with muffler off for very short hit with cart to see if engine revs fast and seems to have no restriction. If you do not see any diff you do not have a plugged muffler.
redcloud is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Marathon running issue Gas EZGO
85 marathon running well, but very loud Gas EZGO
92 EZ-GO Marathon running hot Gas EZGO
marathon running Gas EZGO
90 Marathon Will not stay running Gas EZGO


All times are GMT -5. The time now is 09:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.