Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (http://www.buggiesgonewild.com/)
-   Gas EZGO (http://www.buggiesgonewild.com/gas-ezgo/)
-   -   EZGo Gas 96 Cart will not start (http://www.buggiesgonewild.com/gas-ezgo/84771-ezgo-gas-96-cart-will-not-start.html)

pulsi53 08-27-2013 12:16 PM

EZGo Gas 96 Cart will not start
 
I have a cart that recently replaced Starter/Gen and Voltage regulator. Over the last 2 weeks it was slow to turn over when gas peddle was depressed (thought maybe it was due to not being used for about 2 months and needing to get wormed up). Then yesterday it just would not start.

Checked battery, Starter gen, Voltage Regulator and Solenoid, all came up good.

Anything else i can try?

Thanks

financethis 08-27-2013 01:54 PM

Re: EZGo Gas 96 Cart will not start
 
do you have spark?
are you getting fuel?
do you have compression?

if those check out then it could be a vacuum leak or seal or gasket gone bad.

rugerm77 08-27-2013 06:18 PM

Re: EZGo Gas 96 Cart will not start
 
Starter Turning over Slow , My guess it's in the Starter.

hsdtech 08-28-2013 12:56 AM

Re: EZGo Gas 96 Cart will not start
 
Have you checked the battery?

Edit: I see that you have. I would still check it with a VOM and check the voltage when starting it.


All times are GMT -5. The time now is 09:23 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.