lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-09-2014, 12:04 PM   #1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Ezgo workhorse runs good then starts to sputter and run bad

Hello all. I have a cart that belongs to the community I live in and they asked me to look at it for them. The cart runs good for a while then it will spit and sputter. I have drained the tank flushed the fuel lines and also had the carb pulled apart and cleaned up. I also replaced the plugs and fuel filter. It will run good for a while and then it starts acting up again. Could it be the Lil coil thing with the plug wires coming out from it?
grandpa1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-09-2014, 02:04 PM   #2
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

Anyone have any good ideas
grandpa1 is offline   Reply With Quote
Unread 04-10-2014, 06:49 PM   #3
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

OK I have took the carb apart again and cleaned it . I replaced the coil and still have the same problem. It spits and sputters on takeoff and backfires then when it cleans up it runs fine.
grandpa1 is offline   Reply With Quote
Unread 04-10-2014, 07:03 PM   #4
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

ok time to pull the valve cover and adjust the valves thats the most likely problem set them to .004
nobuckbuild is offline   Reply With Quote
Unread 04-10-2014, 10:01 PM   #5
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

ok I will ck them first thing in the morning and I will post what I find. Thank you so much.
grandpa1 is offline   Reply With Quote
Unread 04-11-2014, 07:32 AM   #6
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

OK I adjusted valves. Same issue. Did not get any better. Maybe worse now
grandpa1 is offline   Reply With Quote
Unread 04-11-2014, 08:49 AM   #7
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

Still no luck. Anyone have any idea
grandpa1 is offline   Reply With Quote
Unread 04-11-2014, 10:25 PM   #8
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

check your compression , these engines are know to blow head gaskets between the cylinders causing this problem you'll get enough gas when choking to get it to run but very bad and will also spit gas back though the intake valve on the other cylinder
nobuckbuild is offline   Reply With Quote
Unread 04-12-2014, 09:52 AM   #9
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

I will have to get a tester then. What is weird is when it clears itself out it runs perfect. But when you stop and try to go again it has to clear itself out again before it runs good again.
grandpa1 is offline   Reply With Quote
Unread 04-12-2014, 09:58 AM   #10
Gone Wild
 
nobuckbuild's Avatar
E-Z-GO
 
Join Date: Mar 2012
Location: CENTRAL PENNSYLVANIA
Posts: 1,466
Default Re: Ezgo workhorse runs good then starts to sputter and run bad

well that would be because with rpms the problem is more hidden
nobuckbuild is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
GAS EZGo Workhorse-Runs doesn't go Gas EZGO
80 EZGO runs good reverse not forward Gas EZGO
91 EZgo 36volt, starts off slow then runs fine? Electric EZGO
EZGO workhorse ..good choice? Gas EZGO
Low speed workhorse sputter Gas EZGO


All times are GMT -5. The time now is 05:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.