lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-27-2014, 01:34 PM   #1
Not Yet Wild
 
Theskullstalker's Avatar
 
Join Date: Aug 2014
Posts: 17
Default G9 pulsar coil

Can someone please tell me why the ground wire for the pulsar coil keeps smoking when I apply the pedal. I also have no spark. I know I keep reading about ground connections but I have messed with every wire possible. I even made a new connection for the ground wire for for the pulsar wire by-passing the plastic factory connector. Someone please respond asap.
I noticed that when its not connected the cart will turn over without any smoking of the wires. NOTE: Its a brand new pulsar coil.
Theskullstalker is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Pulsar coil Gas EZGO
Pulsar coil Golf Carts and Parts
Pulsar coil Gas EZGO
pulsar coil Gas Yamaha
Pulsar coil Gas EZGO


All times are GMT -5. The time now is 12:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.