lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-08-2008, 02:03 PM   #1
Not Yet Wild
 
Join Date: Mar 2008
Posts: 21
Default G16 Gas not charging

Hello all,
I have a G16 that I bought as a gift for my parents last spring. Over the summer I was working on it and bought a new clutch and tires and all, but all summer long the new battery wasnt taking a charge from the starter/gen. I bought a meter and I was checking the voltage of the battery (directly on the battery) when the cart was off and when it was idling and when it was open and running full out.. and I believe battery was registering 12.6, 11.4 and somewhere between 14 and 16 volts respectively.. but it still would drain the battery and then I'd would have to charge the battery after a riding in the cart for 20-30 mins with just normal driving around in the neighborhood. Is there another component that I could check with my voltage meter that has to do with the charging system? Thank you in advance for your input. If there is another part I can check instead of just replacing electronics I'd like to avoid having to buy the expensive parts like the starter.
bramr1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-08-2008, 06:59 PM   #2
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,319
Default Re: G16 Gas not charging

Quote:
Originally Posted by bramr1 View Post
Hello all,
I have a G16 that I bought as a gift for my parents last spring. Over the summer I was working on it and bought a new clutch and tires and all, but all summer long the new battery wasnt taking a charge from the starter/gen. I bought a meter and I was checking the voltage of the battery (directly on the battery) when the cart was off and when it was idling and when it was open and running full out.. and I believe battery was registering 12.6, 11.4 and somewhere between 14 and 16 volts respectively.. but it still would drain the battery and then I'd would have to charge the battery after a riding in the cart for 20-30 mins with just normal driving around in the neighborhood. Is there another component that I could check with my voltage meter that has to do with the charging system? Thank you in advance for your input. If there is another part I can check instead of just replacing electronics I'd like to avoid having to buy the expensive parts like the starter.
Ok, Yor battery reads 12.6 off-good. It drops to 11.4 when you start the car-ok. when reving up the car you read between 14 and 16 volts? You want your charging circuit at 14.5 to 15.5 volts, you should be ok. Did you happen to put a "deep cycle" battery in it ? If so go back to a group 24 automotive battery with at least 600 cold cranking amp rating. Do you have any add on acessories that could drain the battery? That's all I can help with at this time. Good luck and keep us posted.
smallblock450sl is offline   Reply With Quote
Unread 12-08-2008, 07:36 PM   #3
Admin/Moderator
 
TheNewGuy's Avatar
Yamaha
 
Join Date: Dec 2006
Location: Ohio
Posts: 15,879
Default Re: G16 Gas not charging

Make sure your battery terminals are clean and tight.

TheNewGuy is offline   Reply With Quote
Unread 12-10-2008, 09:53 PM   #4
Not Yet Wild
 
Join Date: Mar 2008
Posts: 21
Default Re: G16 Gas not charging

Quote:
Originally Posted by smallblock450sl View Post
Ok, Yor battery reads 12.6 off-good. It drops to 11.4 when you start the car-ok. when reving up the car you read between 14 and 16 volts? You want your charging circuit at 14.5 to 15.5 volts, you should be ok. Did you happen to put a "deep cycle" battery in it ? If so go back to a group 24 automotive battery with at least 600 cold cranking amp rating. Do you have any add on acessories that could drain the battery? That's all I can help with at this time. Good luck and keep us posted.
I have a 685cca battery on the cart, i bought the battery brand new, I thought that was the problem at first..so I have since replaced it with a same type battery. There are no accessories on the cart at all. Other than the starter/generator is there any other components that could be the culprit? Its been a while since I have checked the cart.. and I may be a slight bit off on the charging circuit numbers.. its possible that it only puts out between 13 - 13.5 ...
bramr1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging Electric EZGO
charging Electric Club Car
36v Charging on '05 PDS Electric EZGO
charging Electric EZGO
charging ??? Electric EZGO


All times are GMT -5. The time now is 05:22 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.