lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-16-2015, 07:54 PM   #1
Not Yet Wild
Yamaha
 
Join Date: Sep 2015
Location: Tennessee
Posts: 1
Default Late 80's G1 runs and idles but wont move forward.

I got a late 80's model G1 gas. It runs and idles fine. It will move in reverse but forward is really sluggish and will hardly budge. Clutch seems to be working fine. Could it be a solenoid? rpms seem down when trying to go forward. Could that be an issue? Any advice or something to check will be greatly appreciated!
mattb93 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1, idles great, runs rough, runs better when warm Gas Yamaha
Runs/starts - won't move - forward or reverse Gas Club Car
Late 80's club car 36v wont go in reverse Electric Club Car
Mid 80's Club Car won't move forward Electric golf carts
Late 90's Ez Go Wont Move?? Electric EZGO


All times are GMT -5. The time now is 08:50 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.