lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-17-2016, 08:46 AM   #1
Not Yet Wild
 
Join Date: Oct 2011
Posts: 4
Default G14 Losing power running hot

I have a 1995 G14 that is losing power and running hot. It will not pull two people up a hill now. Also, the engine compartment becomes very hot. On level ground it sometimes runs fine and other times is at a lose for power. The cart runs very rich, not sure how to adjust so directions would be helpful. Fuel lines and filter were replaced at beginning of year. Plan on checking compression this weekend to see if there are other issues. Thoughts?
boatertim221 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-17-2016, 10:00 AM   #2
Gone Wild
 
raydhd's Avatar
Yamaha
 
Join Date: Oct 2014
Location: Fortescue NJ
Posts: 3,094
Default Re: G14 Losing power running hot

Also check that you cooling fins are clear under the engine shrouds.With a valve cover lead it is easy for the fins to get covered in gunk and the engine to overheat.
raydhd is online now   Reply With Quote
Unread 08-17-2016, 02:37 PM   #3
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 8,156
Default Re: G14 Losing power running hot

ignitor may be on the way out. they sometimes retard the timing when they are going out. late timing would really hurt power & it would cause hot running.
cgtech is offline   Reply With Quote
Unread 08-18-2016, 07:51 AM   #4
Not Yet Wild
 
Join Date: Oct 2011
Posts: 4
Default Re: G14 Losing power running hot

I will look into the ignitor and cooling fins. Will let you know what I find.

Thanks.
boatertim221 is offline   Reply With Quote
Unread 08-22-2016, 08:04 AM   #5
Not Yet Wild
 
Join Date: Oct 2011
Posts: 4
Default Re: G14 Losing power running hot

Well, I found the carb was out of adjustment, 2 turns out rather than 1.5 turns and that the muffler gasket is bad. Ordering new gasket today and replacing next weekend so we will see if that helps. Plug was very sooty so will continue to monitor that. Compression was around 160 cold.
boatertim221 is offline   Reply With Quote
Unread 01-11-2017, 10:57 AM   #6
Not Yet Wild
 
Join Date: Oct 2011
Posts: 4
Default Re: G14 Losing power running hot

Forgot to update on what I found.
Carb out of adjustment and dirty airfilter. Once these items were taken care of it seemed to run fine. The air filter seemed to actually be more of the issue. We'll see what happens next summer.
boatertim221 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
yamaha g2 running very rich and losing power Gas Yamaha
Losing power Electric EZGO
Losing power Electric EZGO
82 G1 losing power Gas Yamaha
DS Losing Power Electric Club Car


All times are GMT -5. The time now is 06:26 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.