lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-30-2017, 02:29 PM   #1
Not Yet Wild
 
Join Date: May 2017
Posts: 3
Angry Keep blowing 10 Amp Fuse

2013 Yamaha G 29 ran fine one evening, the next morning nothing. The 10 amp fuse blows every time we push down on the pedal which also causes the back up alarm to go out. If I put a new fuse in the back up alarm will sound and all is fine, then when we press the pedal it pops the fuse. Can't find any bare wires and the yamaha deal gave me a new harness running to the regulator but that didn't solve the problem. Frustrating trying to figure out this negative ground fuse issue. Had this cart 3 weeks with no problems at all.
Marbob621 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-30-2017, 08:23 PM   #2
Not Yet Wild
 
Join Date: May 2014
Posts: 20
Default Re: Keep blowing 10 Amp Fuse

any update on it
nonobaddog is offline   Reply With Quote
Unread 05-30-2017, 10:20 PM   #3
Not Yet Wild
 
Join Date: May 2017
Posts: 3
Default Re: Keep blowing 10 Amp Fuse

No updates. Hoping for smallblock to respond being tha he is the Yamaha guy. Really frustrated.
Marbob621 is offline   Reply With Quote
Unread 05-31-2017, 08:46 AM   #4
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,319
Default Re: Keep blowing 10 Amp Fuse

Don't know about the Yamaha guy, but.....Has the battery been changed? has the starter been out? I would check battery polarity and correct connections first. Since you have found no bare/grounded wires....I would unplug the voltage regulator/engine stop relay/starter charging wires and the back up buzzer micro switch. Now does the fuse blow when pedal pushed? Plug in one component at a time till the fuse blows. Let us know what you find.
smallblock450sl is offline   Reply With Quote
Unread 05-31-2017, 12:20 PM   #5
Not Yet Wild
 
Join Date: May 2017
Posts: 3
Default Re: Keep blowing 10 Amp Fuse

I bypassed the start/stop switch and it started and ran without popping the 10 amp fuse. Should have a new switch tomorrow and should be good to go.
Thanks
Marbob621 is offline   Reply With Quote
Unread 06-01-2017, 11:11 PM   #6
Not Yet Wild
 
Join Date: May 2014
Posts: 20
Default Re: Keep blowing 10 Amp Fuse

let me know how you end up becouse i have a g9 and iam on the seame bout
nonobaddog is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Blowing fuse Gas Club Car
G1 blowing fuse Gas Yamaha
blowing fuse on a 04 iq Electric Club Car
84 G1 Keeps Blowing Fuse Gas Yamaha
Old G1 blowing fuse... Gas Yamaha


All times are GMT -5. The time now is 04:49 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.