lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 01-02-2010, 02:24 PM   #1
Not Yet Wild
 
Join Date: Jan 2010
Posts: 3
Default backfiring G9

I am having trouble with my G9. It wont start. it has good compression , good fire. I put a new ignition coil and ignitor and spark plug on it. It appears to be out of time. It backfires out the carb and the muffler . So could the flywheel key be damaged enough to cause this ? Or what else could it be ?
99fleetwood is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 01-02-2010, 02:32 PM   #2
Are You Ready???
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: middle TN
Posts: 21,880
Default Re: backfiring G9

Check the valves and make sure they are adjusted properly: .004 TDC. If the cart runs but backfires after letting off the gas, it can also be due to the carb. throttle not closing all the way and out of adjustment.

spriddle is offline   Reply With Quote
Old 01-02-2010, 02:40 PM   #3
Not Yet Wild
 
Join Date: Jan 2010
Posts: 3
Default Re: backfiring G9

It won't even start. It was running just fine one day and it stopped running and started kicking backwards like it was tryng to run backwards. I have tried to start it in forward and reverse . I will check the valve clearances and the throttle cable.
99fleetwood is offline   Reply With Quote
Old 01-03-2010, 11:42 AM   #4
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 8,145
Default Re: backfiring G9

Quote:
Originally Posted by 99fleetwood View Post
It won't even start. It was running just fine one day and it stopped running and started kicking backwards like it was tryng to run backwards. I have tried to start it in forward and reverse . I will check the valve clearances and the throttle cable.
Something you could try....The negative battery cable goes to the end plate of the starter/generator, Yamaha "pgitailed" a small gauge wire to it and is connected with a bullit connector to the wire harness. Cut back the electrical tape/cut off the small wire and put your own eye end on it and attatch it to the stud with the negative battery cable. Some G9's also had an "add on" fuse at that connection. The reason to check this? Your electronic ignition is based on "open/closed" ground, if a bad ground, it acts like it's out of time. Good luck Dave
smallblock450sl is online now   Reply With Quote
Old 01-03-2010, 01:36 PM   #5
2nd clone crazed
 
sho305's Avatar
Yamaha
 
Join Date: Jun 2009
Location: West MI
Posts: 9,154
Default Re: backfiring G9

Great tip Smallblock, electrical connections are a weak point on these carts with age but at least they are easy to repair. That or the valves seem most probable, possibly a bad ignitor but they are expensive I'd try to swap one first if you get to that. Look for obvious intake air leak maybe, some carts that can have severe reaction.
sho305 is offline   Reply With Quote
Old 01-03-2010, 02:24 PM   #6
gone yamaha!
 
sabercat's Avatar
Yamaha
 
Join Date: Sep 2008
Location: ontario, canada
Posts: 1,424
Default Re: backfiring G9

other thing that can make it back fire is the mixture could be set too rich which will make it backfire. 1 1/2 turns out for the mixture screw.
sabercat is offline   Reply With Quote
Old 01-03-2010, 11:17 PM   #7
Not Yet Wild
 
Join Date: Jan 2010
Posts: 3
Thumbs up Re: backfiring G9

Thanks smallblock450 ls
The ground and other dirty connections were the problem. I sanded and sprayed with electronic cleaner every connection i could find.: It worked and i now have it running better than it was before. Very good tip !
99fleetwood is offline   Reply With Quote
Old 01-04-2010, 07:40 PM   #8
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 8,145
Default Re: backfiring G9

Quote:
Originally Posted by 99fleetwood View Post
Thanks smallblock450 ls
The ground and other dirty connections were the problem. I sanded and sprayed with electronic cleaner every connection i could find.: It worked and i now have it running better than it was before. Very good tip !
I love it when things work out!
smallblock450sl is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
FE 350 Still backfiring Gas Club Car
Backfiring Buggie Gas EZGO
Backfiring on a ST2+2 Gas EZGO
95 txt backfiring Gas EZGO
backfiring Gas EZGO


All times are GMT -5. The time now is 09:54 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.