lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-04-2010, 11:40 AM   #1
Not Yet Wild
 
Join Date: Jun 2010
Posts: 6
Default Missing linkage off my G1

I was looking at a friends G1 and noticed that my G1 is missing a piece of carb linkage that goes from the carb through the engine cover over the head and around to exhaust pipe which seems to have a flapper in the pipe. What is this for? Is it real important? I am thinking no as mine hasn't been there for awhile.
Cholmes is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-04-2010, 01:03 PM   #2
Gone Wild
 
GMB74's Avatar
Yamaha
 
Join Date: Jun 2009
Location: Heluvabump,VT
Posts: 623
Default Re: Missing linkage off my G1

The flapper in the exhaust was meant to restrict the exhaust at low rpm's. According to the Yamaha manual,this holds the fuel mixture in the combustion chamber and prevents it from rushing out the exhaust at low rpm's and low load. This was done to reduce the noise and rough running resulting from incomplete combustion. It probably also reduced the oily 2-stroke smell you get sometimes. 1982 models did not have this setup, earlier and later ones did. If the mechanism gets worn out or broken, it is usually removed and the holes in the exhaust flange welded up. Unless you prefer to putt-putt from one hole on the links to the next you won't miss not having the flapper. Most people here tend to be the full-throttle type.
GMB74 is offline   Reply With Quote
Unread 07-04-2010, 07:20 PM   #3
Not Yet Wild
 
Join Date: Jun 2010
Posts: 6
Default Re: Missing linkage off my G1

Interesting, I figured it had something to do with low RPM, I use it around my property which is a full throttle kind of place!
Cholmes is offline   Reply With Quote
Unread 07-05-2010, 05:25 AM   #4
Gone Wild
 
chuddly's Avatar
Yamaha
 
Join Date: Mar 2010
Location: Eminence, IN
Posts: 534
Default Re: Missing linkage off my G1

you will fit in just fine here then
chuddly is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
What am I missing for 36 to 48 Marathon? Electric EZGO
Missing Gas EZGO
95 CC Missing hi speed Electric Club Car


All times are GMT -5. The time now is 12:46 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.