lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-22-2010, 06:37 PM   #1
Not Yet Wild
 
Join Date: Jul 2010
Posts: 4
Default G16 stops after 20 min, rests then runs fine

I have a '97 G16 that has served me well for a dozen years. About a week ago, after about 20 minutes run time it started sputtering died, and refused to start. Thought it had run out of gas but after towing it home it ran fine.

Then a few days ago ran the cart for about 20 minutes and it did the exact same thing. Called the wife for a ride home. Went to pick it up the next morning and it ran fine all the way home (3 miles).

Yesterday it did the same thing. Ran perfectly for about 20 minutes, coughed, sputtered and stopped. Parked it and picked it up this morning. It ran perfectly 2+ miles home.

I have checked the spark plug, tan, clean proper gap. Air filter new, no blockage. Fuel filter clean. Fuel flows well.

Checked air cooling for blockage and found none to the intake. Beyond is relatively inaccessible.

Sounds like heat soak is affecting something. Any ideas?
TestPoint is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-22-2010, 06:46 PM   #2
Gone Wild
 
craig tn's Avatar
Yamaha
 
Join Date: Jan 2008
Location: Covington, TN
Posts: 1,910
Default Re: G16 stops after 20 min, rests then runs fine

The coil is going out. Check spark after it quits.
craig tn is online now   Reply With Quote
Old 07-22-2010, 06:49 PM   #3
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 8,089
Default Re: G16 stops after 20 min, rests then runs fine

Just my thoughts, but could be 2 things. Get a "dynamic spark tester" (plugs onto the plug and cap) and when it dies, see if the is any spark. I have had G16 TCI's , when hot, loose spark, when cooled down, they regain spark again, that would call for a new TCI. Second, I would check the "pulsar line" (it's the hose that runs from the fuel pump along side and inder the airbox into the engine) that drives the fuel pump. Have found oil mixes with moisture and partially plugs it. Unhook it from the fuel pump and "blow" back towards the engine, there should be no restriction. Good luck Dave
smallblock450sl is offline   Reply With Quote
Old 07-23-2010, 08:18 AM   #4
Not Yet Wild
 
Join Date: Jul 2010
Posts: 4
Default Re: G16 stops after 20 min, rests then runs fine

I am very familiar with auto mechanics but this cart has been so trouble free that I have never spent much time thinking about it.

I gather from comments that a TCI (what is a TCI?) drives the coil. Replace one of both?

Three character searches do not work.

Anyone got a wiring diagram they would be willing to share?

tp
TestPoint is offline   Reply With Quote
Old 07-23-2010, 09:09 AM   #5
Getting Wild
 
chompy's Avatar
 
Join Date: Jul 2010
Posts: 107
Default Re: G16 stops after 20 min, rests then runs fine

The TCI (Transistor Controlled Ignition) and the coil are an all in one unit.
Attached Images
File Type: jpg G16 wiring diagram.jpg (61.7 KB, 13 views)
chompy is offline   Reply With Quote
Old 07-23-2010, 09:46 AM   #6
Not Yet Wild
 
Join Date: Jul 2010
Posts: 4
Default Re: G16 stops after 20 min, rests then runs fine

Thank you very much for the schematic.

I called the friendly, neighborhood (50 miles away) cart shop, described my problem and they instantly said 'coil'. Guess I will go pick up a coil this afternoon.

Looks a little tight on the side of the engine. Need to remove the gas tank to get to it?

Thanks for the help.

tp
TestPoint is offline   Reply With Quote
Old 07-23-2010, 03:46 PM   #7
Gone Wild
 
craig tn's Avatar
Yamaha
 
Join Date: Jan 2008
Location: Covington, TN
Posts: 1,910
Default Re: G16 stops after 20 min, rests then runs fine

It is a pain but can be done with out removing the tank.
craig tn is online now   Reply With Quote
Old 07-23-2010, 08:42 PM   #8
Not Yet Wild
 
Join Date: Jul 2010
Posts: 4
Default Re: G16 stops after 20 min, rests then runs fine

OK, got the new coil, $120 . . . ouch! locally. $88 plus $15 shipping on the net. I am restoring an old Jaguar and a coil pack is only $105.

For those that come after me . . . removing the fuel tank may not be necessary but sure is easier. Two bolts plus a fuel line and it is out. Empty weights a lot less than full. Had one screw on the air intake cover that was not accessible as was one of the flywheel cover bolts. Ended up removing the tank, and the right side motor mount bolts and then everything was reachable. Put the motor mount bolts back on, loosely, before the fly wheel cover.

On the advice of the local (50 mile) repair shop set the gap between the new coil pickups and the flywheel at a business card thickness. Tore up a strip and set between each of the pickups. Tightened down the bolts and that was that.

Thanks for all that contributed!

Drove it for almost an hour up the steepest hills available and it ran fine.
TestPoint is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
gas clubcar runs fine then dies Gas Club Car
Golf cart runs/starts fine but then it doesnt Gas EZGO
Runs fine but low power! Gas EZGO
Cart runs fine, stop, won't start back Gas Club Car
runs fine at low rpm, high rpm no power bogs down Gas EZGO


All times are GMT -5. The time now is 08:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.