lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-28-2010, 11:27 PM   #1
Not Yet Wild
 
Join Date: Apr 2010
Posts: 3
Default 1985 G1 Runs fine low speed , high speed run for a mile then fall on its face

Well a customer dropped this cart off to me in boxes last week and i got it moving and he took it home on Friday. Today he brought it back to me complaining of the mentioned problems.


As I'm a heavy equipment mechanic i have limited experience with these carts. I removed and cleaned the carb blew out all passages etc , checked needle and seat, float level , fuel flow from the pump , oil pump , crank seals ( with the rudimentary carb spray on the seals ) , Electrical seems all good ( noticed in another post someone having the same problem lost a electrical connection to the mag ) Needle is 1.5 turns out off the seat. New plug and its not smoking much compression is 125

Governor is still hooked up but the linkage to the exhaust valve is gone , going to check to make sure its not causing the issue as it is just flapping in the breeze. I'll remove the butterflies tomorrow if they are still there.

Thanks Mike

PS Any help is appreciated as hes hoping to take it home on friday again for the weekend
mike77z is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-30-2010, 04:37 AM   #2
Gone Wild
 
GMB74's Avatar
Yamaha
 
Join Date: Jun 2009
Location: Heluvabump,VT
Posts: 623
Default Re: 1985 G1 Runs fine low speed , high speed run for a mile then fall on its face

If the exhaust valve is free to close off the exhaust whenever it wants, that could be your problem. It is meant to restrict the exhaust flow at low speeds for smoother running, but if it shuts at high speeds it will choke out the engine. Wire it wide open or remove it and weld up the holes.
A plugged muffler is another possibility. Maybe a mouse nest or nuts floating around in there? I have seen that before.
GMB74 is offline   Reply With Quote
Unread 07-30-2010, 11:32 AM   #3
Vegas modded 420
 
sho305's Avatar
Yamaha
 
Join Date: Jun 2009
Location: West MI
Posts: 14,567
Default Re: 1985 G1 Runs fine low speed , high speed run for a mile then fall on its face

They can plug up with carbon/oil. I had one I had to stick a rod up the outlet and crusty stuff fell out, then it ran fine. Could also be an ignition issue like a coil getting hot...or it is just getting hot from exhaust problem. Yeah valve needs to be open and is not really needed if you want to remove it.
sho305 is offline   Reply With Quote
Unread 09-08-2010, 08:04 AM   #4
Not Yet Wild
 
Join Date: Apr 2010
Posts: 3
Default Re: 1985 G1 Runs fine low speed , high speed run for a mile then fall on its face

Ill have the unit back this week and give that a shot , its lead a hard life since it left the course

Thanks. Mike
mike77z is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
High Speed Gears...??? Electric Club Car
high speed Gas EZGO
1/8th mile best speed Extreme DC!
High speed gears? Gas Club Car
runs fine at low rpm, high rpm no power bogs down Gas EZGO


All times are GMT -5. The time now is 01:20 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.