lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-28-2008, 04:57 PM   #1
Not Yet Wild
 
mark6065's Avatar
 
Join Date: Apr 2008
Posts: 17
Default 85 g1 running good

well got the new seals and the new carb and everything went good putting her all back together. but you wont believe this. after the re-assembly and installing my new carb i started her up and i was suprised how much gas she was now pumping. then out of the over flow tube came all this gas. i was like freaking out new carb now what?. so i took the carb off pulled the bowl and what i found made me laugh. there was a extra jet screw stuck under the float not allowing it to do anything but (wide open) so i removed the jet screw (now i have a extra one) put her back together and installed back onto the cart and walla she runs just like a new one.
mark6065 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-28-2008, 07:45 PM   #2
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,264
Default Re: 85 g1 running good

Quote:
Originally Posted by mark6065 View Post
well got the new seals and the new carb and everything went good putting her all back together. but you wont believe this. after the re-assembly and installing my new carb i started her up and i was suprised how much gas she was now pumping. then out of the over flow tube came all this gas. i was like freaking out new carb now what?. so i took the carb off pulled the bowl and what i found made me laugh. there was a extra jet screw stuck under the float not allowing it to do anything but (wide open) so i removed the jet screw (now i have a extra one) put her back together and installed back onto the cart and walla she runs just like a new one.
Great news! I was impressed how you "asked questions first", got he awnsers and did the job! Now "turn up that govenor" and have some fun! Later Dave
smallblock450sl is offline   Reply With Quote
Unread 04-29-2008, 07:27 AM   #3
Not Yet Wild
 
mark6065's Avatar
 
Join Date: Apr 2008
Posts: 17
Default Re: 85 g1 running good

hey dave. what is the best way to adjust my govenor for the 1985 g-1. heard stories about burning up the engine. i could crank the govenor screw all the way in or is there another option on this particular model i seen the post about govenors but did know if it changes from model to model?
mark6065 is offline   Reply With Quote
Unread 04-29-2008, 09:59 AM   #4
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,264
Default Re: 85 g1 running good

Quote:
Originally Posted by mark6065 View Post
hey dave. what is the best way to adjust my govenor for the 1985 g-1. heard stories about burning up the engine. i could crank the govenor screw all the way in or is there another option on this particular model i seen the post about govenors but did know if it changes from model to model?
I'd take the govenor screw and nut off. Throw away the nut and screw the screw back in all the way. Dave
smallblock450sl is offline   Reply With Quote
Unread 04-29-2008, 11:24 AM   #5
Not Yet Wild
 
mark6065's Avatar
 
Join Date: Apr 2008
Posts: 17
Default Re: 85 g1 running good

wow that made a improvement on my top speed. is it ok to run it like that for any distance my buddy lives a mile down the road.??
mark6065 is offline   Reply With Quote
Unread 04-29-2008, 11:35 AM   #6
Not Yet Wild
 
augiedoggy's Avatar
 
Join Date: Apr 2008
Posts: 60
Default Re: 85 g1 running good

Quote:
Originally Posted by mark6065 View Post
wow that made a improvement on my top speed. is it ok to run it like that for any distance my buddy lives a mile down the road.??
your not disabling the governor.....just upping the rpm's a bit....should be find....btw usually the generator would break down and fail before the motor...the motor can handle a lot higher rpm's than stock...I've been running my G1 with a longer screw screwed all the way in for three years now without any problems....and sometimes a mile or 2 in one run...
augiedoggy is offline   Reply With Quote
Unread 01-16-2009, 01:09 AM   #7
Not Yet Wild
 
Join Date: Jan 2009
Posts: 8
Default Re: 85 g1 running good

On the other forums they use a small pair of vise grips to compress the spring. I guess it is less stress on the governer. I have not tried it yet, just the adjustment screw.
harvestpride is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
88 gas cc dies after running 20 minutes Gas Club Car
can someone help with cart running on its own Electric EZGO
'94 DS sporadic running... Gas Club Car
My cart running Videos


All times are GMT -5. The time now is 01:03 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.