lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-05-2011, 03:37 PM   #1
Not Yet Wild
 
Join Date: Aug 2010
Posts: 19
Default G9 is Backfiring.

I have a G9 that seems to backfire on the bottom end. The cart accelerates well, then abruptly levels off (i assume this is the governor kicking in, although it seems to slow down almost too much, or a little more than I would expect a governor to slow it down). After releasing the pedal and allowing the cart to slow and then depressing the accelerator again, it immediately back fires. Any ideas what could be causing this?
hot_rod93 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-06-2011, 08:08 PM   #2
Admin/Moderator
 
TheNewGuy's Avatar
Yamaha
 
Join Date: Dec 2006
Location: Ohio
Posts: 13,570
Default Re: G9 is Backfiring.

Make sure when you let off the gas the carb is closing all the way, cable adjustment. Tighten the 10 mm nut on the gov located on top of the rear end.

TheNewGuy is offline   Reply With Quote
Old 07-06-2011, 10:30 PM   #3
Shake & Bake
 
rose88's Avatar
Club Car
 
Join Date: Apr 2010
Location: West Tennessee
Posts: 852
Default Re: G9 is Backfiring.

Also check for bad ground as an intermittent spark can cause this as well
rose88 is offline   Reply With Quote
Old 07-07-2011, 09:54 AM   #4
Not Yet Wild
 
thechevyman's Avatar
Club Car
 
Join Date: Feb 2011
Location: indiana
Posts: 61
Default Re: G9 is Backfiring.

My G2 is doing the same thing. I have maxed out the govenor. The thing runs great at full throttle. It does slow down at top speed when I hit the govenor but continues to runs great as long as the pedal is mashed.

If I try to run at 1/2 or 1/4 throttle it sputters and back fires.

I figure my carb is shot so I am just running it at full throttle for now. With the govenor maxed out I run about 17mph at 2900rpm.

If this is an easy fix let me know.
thechevyman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
FE 350 Still backfiring Gas Club Car
G1 Backfiring Gas Yamaha
G16 Backfiring! Gas Yamaha
backfiring G9 Gas Yamaha
backfiring Gas EZGO


All times are GMT -5. The time now is 03:17 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.