lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-05-2008, 04:37 PM   #1
Not Yet Wild
 
Join Date: Jul 2008
Posts: 3
Default Yamaha Gas -Electric Problem?

I have a 1994 Yamaha Gas that was running fine until today when abruptly it wouldn't start after I parked it for about 15 minutes. No electrical power to anything. I checked the battery and it was ok. I found a broken wire and thought that was the problem but after repairing it, still no electrical power.
I've traced every electrical wire and repaired any broken or frayed wires. I took the ignition switch apart and everything looked fine (visibly) but I'm not sure if it might be the problem. I'm not good at electrical troubleshooting and sure would appreciate some advice from you experts out there.
douglasjturner is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-05-2008, 10:26 PM   #2
The Overposter!
 
Yamaha4life's Avatar
Yamaha
 
Join Date: Nov 2007
Location: Dixie
Posts: 1,586
Default Re: Yamaha Gas -Electric Problem?

One really quick thing to check is to see if it has a ground.
Yamaha4life is offline   Reply With Quote
Unread 07-05-2008, 11:49 PM   #3
Gone Wild
 
craig tn's Avatar
Yamaha
 
Join Date: Jan 2008
Location: Covington, TN
Posts: 1,942
Default Re: Yamaha Gas -Electric Problem?

Did you check the fuse?
craig tn is offline   Reply With Quote
Unread 07-06-2008, 03:40 AM   #4
Not Yet Wild
 
Join Date: Jul 2008
Posts: 3
Default Re: Yamaha Gas -Electric Problem?

I will check the ground and the fuse. Could be either or both.
Thanks
douglasjturner is offline   Reply With Quote
Unread 07-06-2008, 08:42 PM   #5
Not Yet Wild
 
Join Date: Jul 2008
Posts: 3
Default Re: Yamaha Gas -Electric Problem?

I think I found the problem. The button switch under the accelerator had some trash collected around it and I removed and cleaned the switch. When I reinstalled the switch, everything worked fine. I hesitate to say it is FIXED because if this golf cart is anything like the lawn mowers I've owned, it has a mind of its own!!
Thanks for your responses (I checked the fuse and the ground; both were ok).
douglasjturner is offline   Reply With Quote
Reply

Tags
electric problem?, gas, no fire, yamaha
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
94 Electric Ezgo Surging Problem Electric EZGO
1996 Electric Electrical Problem Electric EZGO
1987 Yamaha gas cart backfiring problem Gas Yamaha
Yamaha G2: Problem with not staying charged long! Electric Yamaha
electric ez go problem Electric EZGO


All times are GMT -5. The time now is 06:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.