lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-21-2012, 07:49 AM   #1
Not Yet Wild
 
Join Date: Jun 2012
Posts: 4
Default 96 G14 no power

Hello everyone. I have a 96 G14, it was running fine and now its has no power and its popping/backfiring. I did a pm service (oil,plug,filter). I also removed carb and cleaned it out, it had a little dirt but not bad. Then I pulled fuel pump and took it apart and it was clean inside. Reconnected everything and checked fuel pump to see if it was working and it filled a cup up pretty quick. At this point I'm stuck any suggestions would be helpful
jimmol is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-22-2012, 12:04 AM   #2
Gone Wild
 
bigstik40's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Erie, Pennsylvania
Posts: 989
Default Re: 96 G14 no power

Check to make sure your clutches are working properly. Clutches are a very important part of having a good operating cart. You can run the cart in neutral and watch the clutch operation. At low/no speed, the belt should be at the bottom of the primary (engine) clutch and at the top of the secondary clutch (this is low gear). Speed up the engine and watch the clutch operation. At top rpm the belt should have climbed to the top of the primary clutch and at the bottom of the secondary (this is high gear). If your clutches are not working this way, it's like trying to start out in second or third gear. Also check that your belt is not worn, but the clutches are most important. Also, clutches need to be greased occaisionally (check that). Good luck and report your findings. - RAY
bigstik40 is offline   Reply With Quote
Unread 06-22-2012, 06:22 AM   #3
Not Yet Wild
 
Join Date: Jun 2012
Posts: 4
Default Re: 96 G14 no power

Thanks for getting back to me. Clutches have been greased and appear to be working fine. It just seems to backfire and stumble, so i'm not sure if it would be fuel or spark related. If I put it in neutral it will rev up but again it will backfire and eventually get up rpm's
jimmol is offline   Reply With Quote
Unread 06-22-2012, 01:21 PM   #4
Gone Wild
 
bigstik40's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Erie, Pennsylvania
Posts: 989
Default Re: 96 G14 no power

With the checks you have done so far, it looks like fuel may not be the issue, as those checks came up positive. From here, I think maybe some checking into ignition issues may be prudent. Also, even before you dig into the ignition, a compression check would be good information to have to make sure you don't have something bad going on with the valve train. The popping/backfiring could be caused by a sticking valve. Good luck, maybe others with more experience will chime in. - RAY
bigstik40 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1 not starting...no power power coming from magneto? Gas Yamaha
Ezgo dies under power then regains power Electric EZGO
2005 Precedent starts of powered, then loses power, reverse always power Electric Club Car
Power Wise Charger worked after board replaced now back to no power Electric EZGO
have power on ezgo buggy no power light Electric EZGO


All times are GMT -5. The time now is 10:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.