lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-27-2013, 03:16 PM   #1
Not Yet Wild
 
Join Date: May 2013
Posts: 9
Default G1 blowing fuse

My Yamaha G1 keeps blowing fuse coming off the solenoid. There is a 30 amp fuse in it. The fuse is in the picture and its come off where my fingure is. I don't know where it goes. Thanks for any help. I new to this and don't know much.
Attached Images
File Type: jpg IMG_20130627_142026_790.jpg (214.9 KB, 0 views)
961kyle is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-27-2013, 04:44 PM   #2
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: G1 blowing fuse

It should be a 10A fuse. It is the negative fuse. Do you have any accessories, like lights added to the cart?
1989Marathon is offline   Reply With Quote
Unread 06-27-2013, 05:18 PM   #3
Not Yet Wild
 
Join Date: May 2013
Posts: 9
Default Re: G1 blowing fuse

Yes. There is lights and a stereo on it that were on it when I got it.
961kyle is offline   Reply With Quote
Unread 06-27-2013, 05:26 PM   #4
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: G1 blowing fuse

When does the fuse blow? When you are starting it? Running? Lights on? The stereo and light grounds should be taken back to the negative side of the battery, not the frame.
1989Marathon is offline   Reply With Quote
Unread 06-27-2013, 05:38 PM   #5
Not Yet Wild
 
Join Date: May 2013
Posts: 9
Default Re: G1 blowing fuse

After I put a new fuse in it will run for awhile with the lights on or off. Then it will run with the lights off only. Then won't run at all.
961kyle is offline   Reply With Quote
Unread 06-27-2013, 06:00 PM   #6
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: G1 blowing fuse

Quote:
Originally Posted by 961kyle View Post
After I put a new fuse in it will run for awhile with the lights on or off. Then it will run with the lights off only. Then won't run at all.
Are you saying that it will run with or without the lights for a while? Then, without blowing the fuse, you have to turn the lights off to make it run? Then the fuse blows?
1989Marathon is offline   Reply With Quote
Unread 06-27-2013, 06:26 PM   #7
Not Yet Wild
 
Join Date: May 2013
Posts: 9
Default Re: G1 blowing fuse

Quote:
Originally Posted by 1989Marathon View Post
Are you saying that it will run with or without the lights for a while? Then, without blowing the fuse, you have to turn the lights off to make it run? Then the fuse blows?
Yes. Sometimes the fuse will last a few hours. The next fuse will blow in 10 minutes.
961kyle is offline   Reply With Quote
Unread 06-27-2013, 06:36 PM   #8
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: G1 blowing fuse

First thing I would do is disconnect ALL of the non-stock accessory grounds from the frame and see if the fuse still blows. You should always use the battery ground on a Yamaha cart.
1989Marathon is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
powerdrive2 blowing fuse Electric Club Car
blowing fuse on a 04 iq Electric Club Car
84 G1 Keeps Blowing Fuse Gas Yamaha
Old G1 blowing fuse... Gas Yamaha
G1 blowing relay fuse Gas Yamaha


All times are GMT -5. The time now is 01:37 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.