lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Harley Davidson


Post New Thread  Reply
Thread Tools Display Modes
Unread 12-20-2016, 10:29 PM   #1
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 1,798
Default 1976 de40 surprise it runs!

Bought this thing a few weeks ago for a wintertime project. Knew I would have nightmare after nightmare to get it to run, much less restore it the way I want it to be.

Has been sitting in the woods for at least 15 years I know of. Cleaned it up, best I could, removed leaves, acorns, etc. Has rust on floorpan, and a bit of battery tray but mostly solid. Tested motor yesterday, works fine. Ordered a key off eBay and it arrived today. Hooked up 36v good batteries and EVERYTHING WORKS! Could not believe it. All 3 solenoids kicked in, had to work speed control by hand because linkage is rusted away from pedal, but it all works.

Resistor coils warmed up and smoked a bit, but they are rusty, will clean/and/or replace them. Did this just to begin troubleshooting, can't describe how surprised and happy I am about this.

Looked for Go Pedal linkage on several sites can't find it. I can fabricate but thought I would ask if anybody has that setup for sale. Thanks! My lucky day!
Mooncarter is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-22-2017, 07:40 PM   #2
Gone Wild
 
dundeebarnbuggy's Avatar
Club Car
 
Join Date: Oct 2016
Location: Dundee quebec
Posts: 1,453
Default Re: 1976 de40 surprise it runs!

Just looking to see if any of the horseshoe is showing. Way to go!
dundeebarnbuggy is offline   Reply With Quote
Unread 03-22-2017, 09:02 PM   #3
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 1,798
Default Re: 1976 de40 surprise it runs!

Quote:
Originally Posted by dundeebarnbuggy View Post
Just looking to see if any of the horseshoe is showing. Way to go!
Horseshoe is uncomfortable, but has been useful on a couple things lately.

Don't have it all the time though!
Mooncarter is offline   Reply With Quote
Unread 05-14-2017, 09:23 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,730
Default Re: 1976 de40 surprise it runs!

That's sweet that it runs. Have any pics of it? Also, did you ever track down a linkage?
jakesnake27 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Harley Davidson


Thread Tools
Display Modes


Similar Threads
Thread Forum
77 DE40 Wiring diagram Harley Davidson
76' DE40 Harley Davidson Value Electric EZGO
Surprise Surprise!!!! Big Block Talk!
Surprise Videos


All times are GMT -5. The time now is 04:08 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.