lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car > Lithium Club Car


Post New Thread  Reply
Thread Tools Display Modes
Unread 06-26-2019, 07:33 PM   #1
Not Yet Wild
 
Join Date: Aug 2017
Posts: 27
Default Cart slowed from 36mph to 12mph?

I was out yesterday on the road driving back from the course going down a steep hill at about 35 mph when I let off the throttle to coast then felt the car noticeably slow down on its own. (09 precedent club car) When I hit the throttle again the acceleration was significantly less than I'm used to and got only get the cart to about 12mph. I immediately thought perhaps I'd hit the lithium "knee" and the slow down was due to a lack of voltage. But when i got the car home i checked voltage at 54.4 Volts. Then I took it back out after a full charge and it behaved the same although some times when I hit the throttle I notice it starts to go fast for a second or so then drops down to 12mph.

Any ideas? Could i have cracked the magnet on the speed sensor? Could it be a bad solenoid or even bad controller?

Thanks for any suggestions!
sporty2k is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-26-2019, 07:48 PM   #2
Gone Wild
 
Sergio's Avatar
Club Car
 
Join Date: Sep 2012
Location: Charlotte, NC
Posts: 7,178
Default Re: Cart slowed from 36mph to 12mph?

The way it happened I would check the Solenoid first.

If the contacts are sticking the stock Curtis Controller will go into limp mode.

You can measure the voltage across the Solenoid big posts before and after the Solenoid clicks to make sure it goes from a couple of volts to 0v when it clicks.
Sergio is online now   Reply With Quote
Unread 06-26-2019, 11:25 PM   #3
MOD of all BS!
 
NoleFan4Ever's Avatar
Club Car
 
Join Date: Sep 2011
Location: Florida
Posts: 11,544
Default Re: Cart slowed from 36mph to 12mph?

And if not the solenoid, I would go to the speed sensor next. Have had them be intermittent before....
NoleFan4Ever is offline   Reply With Quote
Unread 06-28-2019, 04:52 PM   #4
Not Yet Wild
 
Join Date: Aug 2017
Posts: 27
Default Re: Cart slowed from 36mph to 12mph?

Looked at speed sensor first. The casing was cracked and the magnet itself was broken in 4 pieces. Ordered a new one and will replace tomorrow and report.

Thanks all for the help!
sporty2k is offline   Reply With Quote
Unread 06-29-2019, 07:56 PM   #5
Not Yet Wild
 
Join Date: Aug 2017
Posts: 27
Default Re: Cart slowed from 36mph to 12mph?

strange - replaced the speed sensor but cart went no faster? On to checking the solenoid.
sporty2k is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car > Lithium Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Cart slowed down after repair Electric EZGO
Cart Slowed Down Electric Club Car
Cart slowed to a crawl Electric EZGO
Cart slowed to a creep Electric EZGO
cart slowed to a crawl Electric Club Car


All times are GMT -5. The time now is 05:44 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.