lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Members Rides
Members Rides Golf Carts Only.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-06-2018, 03:35 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2017
Location: Western Mass
Posts: 6
Default HD rear spring issue TXT

I installed a 5" jake's lift kit along with a HD spring set. The shackles are now flat against the frame giving a very stiff ride. Any thoughts on what may have gone wrong. Thanks in advance
mattco270 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-06-2018, 04:44 PM   #2
Not Yet Wild
Club Car
 
Join Date: Jul 2018
Location: Central Ohio
Posts: 68
Default Re: HD rear spring issue TXT

HD springs are going to be much stiffer. Can you post a picture?
BBBHC is offline   Reply With Quote
Unread 08-07-2018, 06:07 AM   #3
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 9,461
Default Re: HD rear spring issue TXT

Quote:
Originally Posted by mattco270 View Post
I installed a 5" jake's lift kit along with a HD spring set. The shackles are now flat against the frame giving a very stiff ride. Any thoughts on what may have gone wrong. Thanks in advance
considering what you described above in red, I believe you might have gotten the wrong springs... did you compare the length of the new springs to your stock ones?

the shackles should look like these....



Sir Nuke is offline   Reply With Quote
Unread 08-07-2018, 04:14 PM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2017
Location: Western Mass
Posts: 6
Default Re: HD rear spring issue TXT

Quote:
Originally Posted by mattco270 View Post
I installed a 5" jake's lift kit along with a HD spring set. The shackles are now flat against the frame giving a very stiff ride. Any thoughts on what may have gone wrong. Thanks in advance
Thanks for the 2 responses. Unfortunately the old ones are gone to check the measurement. If any one has that dimension that would be helpful.
Attached Images
File Type: jpg shackle.jpg (32.2 KB, 0 views)
mattco270 is offline   Reply With Quote
Unread 08-08-2018, 08:40 AM   #5
Not Yet Wild
Club Car
 
Join Date: Jul 2018
Location: Central Ohio
Posts: 68
Default Re: HD rear spring issue TXT

Yeah, that's definitely not right. Jake's has a Youtube channel where they have videos showing how to install their different products. I would recommend watching their hd spring installation to see how they do it.
BBBHC is offline   Reply With Quote
Unread 08-09-2018, 08:49 PM   #6
Gone Wild
 
WVHarley's Avatar
Harley Davidson
 
Join Date: Jul 2009
Location: West Virginia
Posts: 256
Default Re: HD rear spring issue TXT

So you added the diamond plate at the same time you put the lift on? just a general question. Where is he front of the spring mounted? I dont see how that could hav moved position to throw the back that far out. something doesnt add up. How about a few more pics?
WVHarley is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > Members Rides


Thread Tools
Display Modes


Similar Threads
Thread Forum
Unexpected rear spring issue, need some suggestions. Electric Club Car
98 TXT Leaf Spring Issue Electric EZGO
Rear leaf spring kit req'd on EZGO TXT rear seat install? On Road Golf Carts!
Ez go marathon 4"lift rear spring suggestions for rear seat kit. Design Center
Rear leaf spring issue Electric Club Car


All times are GMT -5. The time now is 10:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.