lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > On Road Golf Carts!
On Road Golf Carts! Low to the ground Golf Carts!



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-27-2019, 02:13 PM   #1
Not Yet Wild
 
Join Date: Jan 2019
Posts: 2
Default Power loss or no power at all

Have a 2014 CC precedent with a 6” lift and large tires. Having issues where I Have very little power or sometimes no power at all. Batteries appear to be fine and were reportedly replaced in 2016. I have noticed that when i plug something into the USB it bucks like its running out of power. Shop can’t figure it out. Would love some help
Kurtgregg is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-28-2019, 05:49 AM   #2
Gone Wild
 
BBBHC's Avatar
Club Car
 
Join Date: Jul 2018
Location: Central Ohio
Posts: 1,095
Default Re: Power loss or no power at all

If you can give some readings on your batteries that would help with diagnosing. The more information the better. Total pack voltage as well as individual. The gurus on here will be able to help you get it figured out.
BBBHC is online now   Reply With Quote
Unread 01-31-2019, 06:33 PM   #3
Not Yet Wild
 
Join Date: Jan 2019
Posts: 2
Default Re: Power loss or no power at all

Thanks, Spoke to Mr.Hicks at revolution golf carts, has been very helpfull. Checked the speed sensor, no problems there. Next was voltage, fully charged got about 49.5, drove up a hill and dropped to 37. failed to mention that I am an idiot and never checked the water in the batteries from the time I bought it in May. Just checked, bone dry, took 3.5 gallons of distilled. Might be the issue.
Kurtgregg is offline   Reply With Quote
Unread 02-01-2019, 08:18 AM   #4
Gone Wild
 
BBBHC's Avatar
Club Car
 
Join Date: Jul 2018
Location: Central Ohio
Posts: 1,095
Default Re: Power loss or no power at all

Mr. Hicks is the CC guru! He is truly awesome at taking time to help and solve problems! I, as well as many others on here highly recommend him for any needs on CCs!

Yeah, sounds like those batteries, at best, are on borrowed time.
BBBHC is online now   Reply With Quote
Reply

Tags
low power, no power to climb
Go Back   Buggies Gone Wild Golf Cart Forum > Modified Golf Carts > On Road Golf Carts!


Thread Tools
Display Modes


Similar Threads
Thread Forum
Loss of power Gas EZGO
power loss Electric Club Car
Loss of Power and Batteries Loss Charge Faster Electric EZGO
loss of power Electric EZGO
g9 loss of power Gas Yamaha


All times are GMT -5. The time now is 07:37 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.