lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-26-2020, 11:38 AM   #1
twilliams81
Gone Wild
 
Join Date: Aug 2016
Posts: 522
Default Charging issue on a 48v txt

Can someone explain this to me...I have a 48v txt using a gray powerwise qe Charger and In trying to get it to take a charge the charger seems to be short cycling. It will come one when the voltage falls to about 39.0v and then will charge for about 10 sec up to 55.1V and repeats this over and over. Granted Iím going to need batteries in this thing but why wonít this charge for more than 10 sec at a time? Iíve tried using (2) other known working chargers and Iíve switched out the charging port assembly with (3) other known working ones and the result is the same every time. Is this simply because of the batteries or should I look at something else? Thanks in advance


Sent from my iPhone using Tapatalk
twilliams81 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-26-2020, 11:58 AM   #2
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,405
Default Re: Charging issue on a 48v txt

39v is way too low....... that in itself will kill batteries. The charger may be having an issue with how heavy the draw is at this low voltage? IDK is there another charger yo can use to bring the pack up to say 47-48v and then retest the OEM charger...
scottyb is offline   Reply With Quote
Unread 03-26-2020, 01:13 PM   #3
twilliams81
Gone Wild
 
Join Date: Aug 2016
Posts: 522
Default Re: Charging issue on a 48v txt

Iím do but more than likely the batteries are going to be replaced. I was just curious about this because i have never seen it before.


Sent from my iPhone using Tapatalk
twilliams81 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging Issue, possible OBC issue Electric Club Car
Charging Issue 99 DS Electric Club Car
Charging issue, but deeper issue? Gas Columbia ParCar
charging issue ? Electric Club Car
Charging Issue/ Battery Issue? Electric EZGO


All times are GMT -5. The time now is 03:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.