lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-25-2020, 08:48 AM   #1
hawkgt
Not Yet Wild
 
Join Date: Nov 2019
Posts: 1
Default Admiral MOT-B4 instal in TXT

Yesterday I installed a Admiral MOT-B4 in my TXT golf cart with previously upgraded to 48V, XCT controller and HD solenoid. The motor went in fine and I used the Alltrax Toolkit utility to upload the field map . My problem is with the speed sensor. I cut off the stock PDS speed sensor and the plug to the speed sensor installed on the B4 and spliced the two together but upon testing it is only running at ~5% power. If i unplug the speed sensor from the XCT it runs the same, ~5% output. If I disable the speed limit in the utility the motor operates at full power. I have it wired red to pink, black to black, white to green. I also tried 4 and 8 pole settings in the utility. Any suggestions other than running without the speed limit?
Attached Images
File Type: jpg 20200324_150817.jpg (205.1 KB, 0 views)
hawkgt is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-25-2020, 09:39 AM   #2
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 69,365
Default Re: Admiral MOT-B4 instal in TXT

The correct setting for all Admiral motors is 4 pole. The Correct field map will automatically set the pole count.
Double check a few things.
The spliced connections color matched correctly, they are secure and isolated.
The controller plug is inserted fully and the retainer clip is lining up and engaged.
If the cart is programmed for an FN device that device is also connected properly.
Note
It is possible to insert the plug in the controller backwards
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 CCP reducer instal Electric Club Car
Precedent stereo instal Electric Club Car
Stereo instal Electric Club Car
instal clone motor Gas Yamaha
Should I instal a govenor? Gas Harley Davidson


All times are GMT -5. The time now is 12:58 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.