lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-14-2020, 01:47 PM   #1
Mathew1700
Not Yet Wild
 
Join Date: Jan 2020
Posts: 14
Default Rebuilding Bad Boy Ambush 2013

After 3.5 years with a small engine repair guy I got my Ambush back in worse condition than when I turned it in.

Found a service/repair manual for 2007 EZGO gas golf cart and a 2010 service/repair manual for EZGO electric golf cart, figure that will at least get me started while I am still rooting around for the actual service manual for the ambush.

Starting with trying to charge the batteries (I can hear you laughing). The service guy suckered me into buying 4 new Duracell ultra batteries, so I at least have to try. I had a closed battery for the gas side, it charged right up.

Plan of attack: Friday, my brother is going to help me change oil, spark plugs and pump out gas to see if we can get the gas engine going. My brother is mechanically inclined, me not so much.

I am completely open to suggestions on how to attack this buggy to get it going again.
Attached Images
File Type: jpg IMG_2705.jpg (217.5 KB, 0 views)
Mathew1700 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-17-2020, 03:47 PM   #2
Mathew1700
Not Yet Wild
 
Join Date: Jan 2020
Posts: 14
Default Re: Rebuilding Bad Boy Ambush 2013

Gas Engine: Pumped out the old gas. There was zero oil in the engine, added oil. Charged up the closed gas engine battery. Checked the load capacity of the gas battery it was barely in the acceptable range.

Electric side: Charged all the electric batteries. Was getting 13.6 volts on all the batteries, but when I check the load capacity on the batteries for the electric engine, only two out of four batteries were showing an acceptable load capacity. Reconditioning the batteries now. Unable to move utv in electric mode.

However there was enough battery power was that I was able to get power to the dash and gas engine. Was pleased that the gas engine stared (after 3.5 years of sitting) and I was able to go both forwards and backwards in gas mode. Course the direction selector crapped out after a few tries going backward and forward, which is a major problem with the 2013 Ambush. We tried wielding in a bracket on the Actuator Box to stabilize the Actuator, before we had turn it in for service. But obviously we still need to work on the directional actuator. Choke valve cable is frozen, trying to loosen it. Need to add fluid to both front and rear axles.

Going to recondition all the batteries, hopefully will have choke valve ready to reinstall when (IF) batteries are reconditioned.

Still trying to find a Service and Repair Manual . Now that I have 3 post thought I would start by pm members that have given out manual in the past.

Attached picture of bracket we wielded onto the actuator box 4.5 years ago to try to stabilize the actuator box. Bracket in upper left hand corner.IMG_2711.jpg
Mathew1700 is offline   Reply With Quote
Unread 02-12-2020, 04:46 PM   #3
Mathew1700
Not Yet Wild
 
Join Date: Jan 2020
Posts: 14
Default Re: Rebuilding Bad Boy Ambush 2013

Making Progress:
With new fuel pump and choke cable, gas engine working and buggy going forwards and backwards in gas mode.

Sanded, epoxy painted battery boxes and put in all new batteries. Buggy will go forward but NOT backwards in electric mode. Still working without a manual.

Can anyone point me in the right direction as to why I can go forward but not backwards in electric mode?
Thanks for your thoughts
Mathew1700 is offline   Reply With Quote
Unread 02-14-2020, 06:23 AM   #4
49ford
Gone Wild
E-Z-GO
 
Join Date: Nov 2011
Location: SW MO
Posts: 184
Default Re: Rebuilding Bad Boy Ambush 2013

You might try contacting the controller manufacturer for info on that piece. Do the usual inspection of all wires, especially connections, and switches, such as forward and reverse. Kind of non specific, but might help. Most of these guys who have had experience with these are reluctant to talk about them.
49ford is offline   Reply With Quote
Unread 02-14-2020, 08:02 AM   #5
Mathew1700
Not Yet Wild
 
Join Date: Jan 2020
Posts: 14
Default Re: Rebuilding Bad Boy Ambush 2013

Thanks, will do.
Mathew1700 is offline   Reply With Quote
Unread 02-20-2020, 06:40 AM   #6
Mathew1700
Not Yet Wild
 
Join Date: Jan 2020
Posts: 14
Default Re: Rebuilding Bad Boy Ambush 2013

Buggy will go forward in electric mode, but if I stop for more than 6 seconds, it "Clicks" into fault mode and will not go forward. Turn it off and back on, fault clears and buggy will go forward again. As long as I press on the pedal again before 6 seconds, it will continuing going forward.

It will not go backwards, but it does rock, forwards than backwards, before giving the same fault, 13 on SepEx controller, which is suppose to be speed sensor.

Replaced the speed sensor, no difference. Still working with out manual for this model year. Received manual for 2014 IS, a lot of differences between 2013 non IS and 2014 IS.

Help, thoughts please!!!! This is basically an EZGO electric golf cart.
Mathew1700 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2013 Badboy Ambush Not Running Electric EZGO
2013 Bad Boy Ambush Actuator Problems Electric EZGO
2013 club car Precedent vs 2013 EZGO RXV Electric Club Car
2013 Bad Boy Ambush 48v/Gas INFO!!! Electric EZGO
2013 Bad Boy Ambush Actuator Problem Electric Club Car


All times are GMT -5. The time now is 09:53 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.