lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-05-2010, 06:29 AM   #1
golfc
Not Yet Wild
 
Join Date: Jul 2010
Posts: 2
Default lights not working

I have a 90 ezgo gas and the lights were working and they suddenly stopped. I found two fuses in the engine compartment and they are fine. I took the light switch out and connected the wires and still no lights.. I am not sure what to check next. it looks like the lights are grounded to the frame. thanks for your help
golfc is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-05-2010, 10:02 AM   #2
WILD-BILL
Gone Wild
 
WILD-BILL's Avatar
E-Z-GO
 
Join Date: Jun 2009
Location: BROOK PARK, OH
Posts: 194
Default Re: lights not working

Have you tried replacing the bulbs? Check your grounds. Check to see if you have voltage at the bulb socket and work back from there.
WILD-BILL is offline   Reply With Quote
Unread 07-05-2010, 12:30 PM   #3
BigRed77
Not Yet Wild
 
BigRed77's Avatar
E-Z-GO
 
Join Date: Nov 2009
Location: Horseshoe Bay, Texas
Posts: 72
Default Re: lights not working

check that ground to the chassis very closely, that is a common spot for circuits to lose connection
take off the bolt or screw, whatever is the end of the ground wire and clean it up and make sure its grounded actually to the metal, not just to the paint
BigRed77 is offline   Reply With Quote
Unread 07-05-2010, 02:23 PM   #4
golfc
Not Yet Wild
 
Join Date: Jul 2010
Posts: 2
Default Re: lights not working

I ended up attaching the positive wire to the ignition wire and it works fine now, the grounds and bulbs were ok. I am not sure if I need a fuse though?? thanks for the help. I can see now:)
golfc is offline   Reply With Quote
Unread 07-05-2010, 02:58 PM   #5
pansser
ZONE FREE ZONE
 
pansser's Avatar
E-Z-GO
 
Join Date: Nov 2009
Location: lauderdale by the sea
Posts: 571
Default Re: lights not working

fuse: YES
pansser is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 Club Car Lights not working Electric Club Car
Brake lights quit working Electric Club Car
Western golf cart, no lights and power hood latch not working Electric golf carts
97 EZGO Lights quit working Electric EZGO
lights quit working Electric EZGO


All times are GMT -5. The time now is 12:53 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.