lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
Thread Tools Display Modes
Unread 11-28-2016, 12:03 PM   #1
Not Yet Wild
 
Join Date: Apr 2015
Posts: 23
Default Star EV just died

Well here's my story. I have a 48V Star EV that was running great up until Friday afternoon. Took it for a 2 mile ride, and started making a scratching noise like i was dragging something, pulled over and didn't see anything underneath.

Went to head home and it just stopped. Checked the batteries and they are all good, hear the solenoid "click", but when I meter I get 50V off the two terminals. Do not have power to the motor though

Need some help
thecabralfamily is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-04-2016, 07:21 AM   #2
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 772
Default Re: Star EV just died

Start looking at motor. You didn't mention what year, but I find lots of motor issues with those cars.
Golf cart guy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ GO Died Electric EZGO
It just died. Electric EZGO
'03 TXT with PDS died Electric EZGO
it died Gas EZGO
just died on me. Gas EZGO


All times are GMT -5. The time now is 12:45 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.