Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Electric EZGO (https://www.buggiesgonewild.com/forumdisplay.php?f=16)
-   -   1997 ezgo electric golf cart (https://www.buggiesgonewild.com/showthread.php?t=39007)

rltcmp 09-22-2010 03:57 PM

1997 ezgo electric golf cart
 
my cart had been running ok then when I went to accelarate it was as if it would not go into gear. It has a sound of like a plastic gear is not engaging to turn the wheels. Can anyone advise me on what I need to do? This is not a battery problem, they are charged. thanks

rib33024 09-22-2010 04:08 PM

Re: 1997 ezgo electric golf cart
 
Welcome to BGW

can you listen closer to the noise and figure out where it is coming from, it sounds like a striped brake drum on the read axle?

rltcmp 09-22-2010 04:30 PM

Re: 1997 ezgo electric golf cart
 
sounds more like from the middle of the axile, but I am courious about your response on how that would have anything to do with it not engaging, the brakes are not locked up, thanks for the reply.

rib33024 09-22-2010 05:01 PM

Re: 1997 ezgo electric golf cart
 
Ezgo's are known for striping out the brake drum,--the axle has a spline on it that the brake drum fits on to drive the the cart, and it strips out, an easy way to check it is to, jack up the cart put it on jack stands, pull the wheel off and remove the center cap so you can see the castle nut that holds the drum on the axle,have some one ut there foot on the brake and then push the go pedal just a little, while you look at that nut and see if it is spinning, and the drum is not.
But if you think it is coming from the center where the motor hook up to the rear end, you need to pull the motor off and see whats up in there



O and Welcome to BGW

COURTESYCART 09-23-2010 08:32 AM

Re: 1997 ezgo electric golf cart
 
I have seen the collar from the motor to input shaft of diff strip, but its very uncommon.

I would have 2 agree with RIB. It sounds like you have a stripped hub/brake drum. If you replace them make sure you torque that castle nut to atleast 80 ft lbs. Also do not back off the nut to put in cotter pin, keep tighting until the pin goes in.

rltcmp 09-23-2010 08:39 PM

Re: 1997 ezgo electric golf cart
 
where is the spline located?

rib33024 09-23-2010 09:21 PM

Re: 1997 ezgo electric golf cart
 
the spline is on the end of the axle, and the in side of the drum, where the drum slides on the axle, it's hard to see in the pic but rite there on the end of the axle.--at the bottom of the pic





http://i762.photobucket.com/albums/x...MS/EZGO3-1.jpg

rltcmp 09-24-2010 10:23 AM

Re: 1997 ezgo electric golf cart
 
the spline on the right side axle is worn out on the hub, the other is ok, however the noise that I hear is coming from the motor area. The rear axle will turn (both sides) when i run the motor, however, it is not engaged because I can hold the axle and it just spins. and suggestions where to start on this? thanks for your help.

rltcmp 09-24-2010 08:06 PM

Re: 1997 ezgo electric golf cart
 
RIB......thanks for the help, I'm back up and running the fairways. Your info was very helpful. Thanks again.

todo_brane_ded 09-24-2010 08:48 PM

Re: 1997 ezgo electric golf cart
 
Quote:

Originally Posted by rltcmp (Post 460265)
RIB......thanks for the help, I'm back up and running the fairways. Your info was very helpful. Thanks again.

Um, so if it wasn't the spline what was the problem?????:scratch:


All times are GMT -5. The time now is 08:32 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.