Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Electric Club Car (https://www.buggiesgonewild.com/forumdisplay.php?f=13)
-   -   MCOR / Pedal Assembly Confusion Explained (https://www.buggiesgonewild.com/showthread.php?t=97696)

PingEye3 09-30-2014 06:10 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
I have 2006 CC Prec with Gen 1 pedal assy. Question: will the Gen 2 assy physically fit as a replacement for Gen 1?

TahoeDawgZ71 10-13-2014 10:15 AM

Re: MCOR / Pedal Assembly Confusion Explained
 
Quote:

Originally Posted by PingEye3 (Post 1081417)
I have 2006 CC Prec with Gen 1 pedal assy. Question: will the Gen 2 assy physically fit as a replacement for Gen 1?

Yes. It's the only one they make now.

kuntryboy 02-19-2015 01:17 AM

Re: MCOR / Pedal Assembly Confusion Explained
 
Tahoe Dawg....

I have the 2009 Club Car Precedent I2 Excel. It still had the TPS throttle in it when I upgraded to a 1268 controller. I was getting an accelerator code so my local dealer had an Mcor2 with adapter on hand. I replaced the TPS with the Mcor2 and got rid of the code. I'm still only getting 44% from the throttle and I think it's because the adapter I used does not have the resistors you spoke of in it. I am searching high and low for the correct adapter for the Excel cart, with the resistors. Do you have any idea what that part number is, or where I can find it?

TahoeDawgZ71 02-20-2015 09:26 AM

Re: MCOR / Pedal Assembly Confusion Explained
 
Part number 103682701

Any club car dealer would be able to order it for you.

Sergio 02-20-2015 09:46 AM

Re: MCOR / Pedal Assembly Confusion Explained
 
I saw that part number but was afraid of suggesting it, the description for the item says: Harness, Jumper, Mcor, Excel and IQ

If there are 2 versions of this adapter, one with resistors and one without, I could not tell by the description of the part #.

I saw that part number in both the 2009 & 2010 precedent IPL, no other part numbers are listed for the TPS to MCOR conversion in either catalog.

Is there a different part number for the adapter that goes into an IQ cart (supposedly without the resistors)?

TahoeDawgZ71 02-20-2015 01:21 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Quote:

Originally Posted by Sergio (Post 1123217)
I saw that part number but was afraid of suggesting it, the description for the item says: Harness, Jumper, Mcor, Excel and IQ

If there are 2 versions of this adapter, one with resistors and one without, I could not tell by the description of the part #.

I saw that part number in both the 2009 & 2010 precedent IPL, no other part numbers are listed for the TPS to MCOR conversion in either catalog.

Is there a different part number for the adapter that goes into an IQ cart (supposedly without the resistors)?

There was a different adapter for the IQ car that didn't include any resistors, but I do not remember the part number. It's no longer available. The only one you can get is the one for Excel.

Camogolfcart 02-21-2015 09:19 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Tahoedawg, I've read a bunch if your posts but cant find one exactly like my issue. Today my precedent backed out of the garage just fine, started to move in forward then all of a sudden lurched then slowly rolled to a stop moving only about 12 feet. If I flip the run/tow switch a couple times then turn the cart on itll work for about 15 yards at very low speeds before it again comes to a stop. My 8 volt batteries all read 7 then at full charge the whole pack read 53. My lights, backup buzzer and the radio work just fine. I've tried to reset my OBC a couple times and it doesn't seem to help. One of the cart shops here thinks it is my mcor but I figured I'd ask you seeing you are able to fix so many peoples issues on this forum. Sorry for the long post. Thank you!

http://www.buggiesgonewild.com/elect...olls-stop.html

kuntryboy 02-22-2015 04:41 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Quote:

Originally Posted by Camogolfcart (Post 1123724)
Tahoedawg, I've read a bunch if your posts but cant find one exactly like my issue. Today my precedent backed out of the garage just fine, started to move in forward then all of a sudden lurched then slowly rolled to a stop moving only about 12 feet. If I flip the run/tow switch a couple times then turn the cart on itll work for about 15 yards at very low speeds before it again comes to a stop. My 8 volt batteries all read 7 then at full charge the whole pack read 53. My lights, backup buzzer and the radio work just fine. I've tried to reset my OBC a couple times and it doesn't seem to help. One of the cart shops here thinks it is my mcor but I figured I'd ask you seeing you are able to fix so many peoples issues on this forum. Sorry for the long post. Thank you!

http://www.buggiesgonewild.com/elect...olls-stop.html

Tahoe and Sergio I'm sure could answer this much better than myself. But it sounds like you may be either having a problem with your solenoid or possibly the diode. Either way they'll probably need more info about your cart to help diagnose it better so go ahead and list your cart year, make, model and any mods to help out.

Camogolfcart 02-22-2015 04:46 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Hey thanks and I'm sorry I should have let everyone know I am actually working on this under a separate thread with Sergio

TahoeDawgZ71 02-22-2015 09:44 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Sounds like the symptoms of a bad MCOR to me, Unplug the MCOR and jump the 2 pin connector with a paperclip and see if it works. Let me know what you find.


All times are GMT -5. The time now is 07:55 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.