Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Electric EZGO (https://www.buggiesgonewild.com/forumdisplay.php?f=16)
-   -   Powerwise II Parts? (https://www.buggiesgonewild.com/showthread.php?t=186238)

TxMasterBoat 09-05-2022 09:39 PM

Re: Powerwise II Parts?
 
1 Attachment(s)
The relay looks like itís pretty burned up. Thanks for all your help so far! Where can I find a replacement board at?

sthreatt 09-06-2022 07:21 AM

Re: Powerwise II Parts?
 
Quote:

Originally Posted by TxMasterBoat (Post 1907546)
The relay looks like itís pretty burned up. Thanks for all your help so far! Where can I find a replacement board at?

eBay, about $45 . Had to replace one about two weeks ago.

TxMasterBoat 09-06-2022 03:35 PM

Re: Powerwise II Parts?
 
Quote:

Originally Posted by sthreatt (Post 1907569)
eBay, about $45 . Had to replace one about two weeks ago.

Awesome thanks you! Do you happen to have the part number still?

sthreatt 09-06-2022 03:54 PM

Re: Powerwise II Parts?
 
Quote:

Originally Posted by TxMasterBoat (Post 1907675)
Awesome thanks you! Do you happen to have the part number still?

Manufacturer Part Number:
603197 5957

TxMasterBoat 09-07-2022 09:51 AM

Re: Powerwise II Parts?
 
Quote:

Originally Posted by sthreatt (Post 1907676)
Manufacturer Part Number:
603197 5957

I ordered one last night, thanks again!

I jumped the relay to charge it last night, and the batteries now show 39v. But the battery indicator on the cart is still blinking low battery. Is there a reset or something I need to do?

radioman 09-08-2022 12:06 PM

Re: Powerwise II Parts?
 
Quote:

Originally Posted by kgsc (Post 1907367)
Which diode assembly do you have? Is it just a barrel mounted to a board? Or an assembly?

If it is just the barrel look on the old ones and see if there is an arrow on the side

The diode is a stud mount 1N1188A. Diode arrived today and installed. Charger works great. Things I learned and observed: When checking diodes in circuit disconnect both. Diodes usually short out but not always. One open diode causes loud hum in transformer and low amps output. The transformer secondary gets extremely hot if left connected to cart charging at low rate.

TxMasterBoat 09-09-2022 02:33 PM

Re: Powerwise II Parts?
 
Quote:

Originally Posted by kgsc (Post 1907466)
What he said. With the charger plugged into the cart check for voltage on the small red and black wires at the top of that board. If there replace the relay board

The new relay board came in. I installed it and still doesnít charge. Same issue it seems like, no buzz and no sounds at all.

kgsc 09-09-2022 03:02 PM

Re: Powerwise II Parts?
 
Could be the board that controls the relay. Go back to the diagnostic manual and see what you find.

TxMasterBoat 09-09-2022 06:52 PM

Re: Powerwise II Parts?
 
Also something Iíve noticed, when I jump the relay to charge the cart, it start out at about 20 amps on the charger gauge, and slowly trickles down to 10 amps. I donít know if that has anything to do with my problem.

radioman 09-10-2022 08:35 AM

Re: Powerwise II Parts?
 
Using a jumper to bypass relay to charge the batteries is a bad idea. The current drop you notice may be a result of overcharged batteries. The bad relay you removed had a melted place around one of the power connections. This may have been caused by a poor connection with the mating connection. Suggest you double check for 36 volts across the small wires again when you plug charging cable into cart.


All times are GMT -5. The time now is 07:50 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.