Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Electric Club Car (https://www.buggiesgonewild.com/forumdisplay.php?f=13)
-   -   MCOR / Pedal Assembly Confusion Explained (https://www.buggiesgonewild.com/showthread.php?t=97696)

manimal13 04-29-2020 10:27 AM

Re: MCOR / Pedal Assembly Confusion Explained
 
Quote:

Originally Posted by jakesnake27 (Post 1712409)
Ah, you've got the old pot box! You'll need a pre-MCOR to MCOR4 conversion kit (link below).

https://www.revolutiongolfcars.com/p...conversion-kit

This is why I love this place. Thanks so much yall!!!

jakesnake27 04-29-2020 10:28 AM

Re: MCOR / Pedal Assembly Confusion Explained
 
Quote:

Originally Posted by manimal13 (Post 1712420)
This is why I love this place. Thanks so much yall!!!

:thumbup: :thumbup:

NoleFan4Ever 04-29-2020 02:25 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Loved the Pot Box's. Still have to OEM ones in service today. '95 & '96 Series carts.

fk94sln 04-29-2020 06:04 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Have a 2012 cc president with mcor 4 having an issue runs fine unless i leave the run/tow switch on overnight next day cart runs slow until i shut run/tow switch off for a minute or so then runs fine again?? mcor problem?? or controller problem?? also sometimes when i turn the run/tow switch on reverse alarm wont turn on until i press the peday like 4-5 times???

jakesnake27 04-29-2020 06:42 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Quote:

Originally Posted by fk94sln (Post 1712616)
Have a 2012 cc president with mcor 4 having an issue runs fine unless i leave the run/tow switch on overnight next day cart runs slow until i shut run/tow switch off for a minute or so then runs fine again?? mcor problem?? or controller problem?? also sometimes when i turn the run/tow switch on reverse alarm wont turn on until i press the peday like 4-5 times???

:sign3: to BGW

The OBC (on board computer, for charging) goes to sleep after awhile, so pumping the pedal to wake it up is completely normal. As for your issue of running slow, that could be a failing speed sensor. Does it do it every time you take the cart out?

WalterM6 04-29-2020 06:49 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
So leave the run/tow sw on. No need to turn it off unless your going to tow it as the name implies.

fk94sln 04-29-2020 07:18 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
Not every time just started happening lately batteries are only year and a half old and are at 50.2 to 50.9 after full charge

Sergio 04-30-2020 11:44 AM

Re: MCOR / Pedal Assembly Confusion Explained
 
The slow until you cycle the Tow/Run could be an indication the Solenoid is contacts are getting stuck (welded).

When that happens the cart runs at 50% power.

fk94sln 04-30-2020 12:51 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
should i just replace the solenoid?

Sergio 04-30-2020 01:17 PM

Re: MCOR / Pedal Assembly Confusion Explained
 
That is probably the best approach.

You could try to tap the Solenoid with a hammer wood handle when the cart is running slow to see if the issue was the contacts not releasing, but in the Precedent that is a difficult job due to the solenoid location.


All times are GMT -5. The time now is 06:26 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.