Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Gas Club Car (https://www.buggiesgonewild.com/forumdisplay.php?f=14)
-   -   2019 Onward Kohler Issues (https://www.buggiesgonewild.com/showthread.php?t=157420)

banjoman2255 08-11-2020 02:10 PM

Re: 2019 Onward Kohler Issues
 
billyGA709, the 02 sensor is a black plug on top of the engine right under the exhaust. Unplug it and it will cure your issues. You will have the check engine light come on though. Sad that we pay this much for Onwards and they do this .

Vince B333 08-11-2020 02:42 PM

Re: 2019 Onward Kohler Issues
 
BillyGA709 -

Have you tried disconnecting the charcoal canister as I have mentioned in a couple of posts up (with picture). Mine has been running great with it disconnected. I did NOT have to disconnect the O2 sensor and therefore check engine light does not come on and stay on. Just for grins, I re-connected it a couple of weeks ago and in two days problems resurfaced. Disconnected again and all is A-OK.

billyGA709 08-29-2020 07:17 PM

Re: 2019 Onward Kohler Issues
 
Banjo and Vince - Thanks for the tip on unplugging the O2 sensor and/or disconnecting the charcoal canister. I will keep that in mind if/when the problem resurfaces as well as turn the key off for a minute or two, long enough for it to reset as someone suggested somewhere in this thread. The dealer called me about two weeks ago and has ordered the parts related to the service bulletin. However, the problem has not resurfaced in at least two weeks or more and we ride the cart almost daily. It has about 60 hours on it now and the issue has occurred on maybe four separate occasions with greatly increased time between each occurrence. I'm thinking the issue has corrected itself but I realize it might reoccur tomorrow. I am careful not to completely top off the fuel tank, not sure if that helps but it's worth a shot. I might not let the dealer tinker with it unless it acts up again.

Doc 09-02-2020 11:37 AM

Re: 2019 Onward Kohler Issues
 
My .02, and yes, I DO have a dog in this fight- I would take the cart back to the dealer and have them fix it and fix it right. There is no excuse to pay this kind of money and have the cart not meet basic (and legal, mind you) expectations. I say legal because this is emissions-related and will dog you for years down the road if not repaired correctly. I've spoken to no less than 6 people who have had similar issues with the new Kohler engines. Club Car needs to know about this so the issue can be addressed and corrected. God, I with they could've stayed with the Kawasakis!

ellis056 09-09-2020 11:21 AM

Re: 2019 Onward Kohler Issues
 
2 Attachment(s)
I have a 2020 Onward with about 30 hours on the motor. Fouled the first spark plug around 20 hours and had to replace it. This one is still running ok for now, but I just found something that I'm curious about. On the Air filter cap there's a Rubber valve covering the inlet tube. Anyone know why the heck this thing would be on here restricting air flow?

I just wonder if maybe this has something to do with fouling spark plugs. Maybe the computer can't adjust the mixture enough to compensate for the restricted air flow? I just took mine off and will see how it runs for a while.

Edit* I found the second inlet hole on the bottom side of the air box. Definitely not the problem.

Karpsta 04-05-2021 09:31 AM

Re: 2019 Onward Kohler Issues
 
So has anyone hear if Kohler/Club Car have an actual solution to this issue yet? We had our dealer replace the O2 sensor and ECU back in December (took a month to get the parts) and we're back to having the same issues.

Unfortunately we have only 1 dealer near us, and they are pretty worthless.

Doc 04-05-2021 03:46 PM

Re: 2019 Onward Kohler Issues
 
Quote:

Originally Posted by Karpsta (Post 1817104)
So has anyone hear if Kohler/Club Car have an actual solution to this issue yet? We had our dealer replace the O2 sensor and ECU back in December (took a month to get the parts) and we're back to having the same issues.

Unfortunately we have only 1 dealer near us, and they are pretty worthless.

Nope...complete and utter silence from both CC AND Kohler. I had a chance to buy 4 of these back in Jan of this year for a song (if I took them all and took them "as-is") and I noped to the entire deal. Great looking carts, but with that Kohler drivetrain they may as well be garbage. I cannot believe that Club Car paired up with that company...they have a VERY long history of producing junk engines. They're going to impact Club Car and their reputation. The Kohler of the past is long gone....seriously, I'd rather have an engine from Harbor Freight than one from Kohler. Yes, they're THAT bad....

YoToddy 05-04-2021 03:42 PM

Re: 2019 Onward Kohler Issues
 
Quote:

Originally Posted by banjoman2255 (Post 1723054)
I had my dealer adjust my throttle cable. I get 28mph on gps but it's wound up pretty tight at that speed. Cruises comfortably at 24ish. Dealer replaced my 02 sensor and have not had any issues sputtering since.

How are you getting that speed? I just bought a 6 passenger 2021 Lifted Onward and I'm topping out at 18-19mph!

billyGA709 05-15-2021 08:37 AM

Re: 2019 Onward Kohler Issues
 
Quote:

Originally Posted by billyGA709 (Post 1755279)
Banjo and Vince - Thanks for the tip on unplugging the O2 sensor and/or disconnecting the charcoal canister. I will keep that in mind if/when the problem resurfaces as well as turn the key off for a minute or two, long enough for it to reset as someone suggested somewhere in this thread. The dealer called me about two weeks ago and has ordered the parts related to the service bulletin. However, the problem has not resurfaced in at least two weeks or more and we ride the cart almost daily. It has about 60 hours on it now and the issue has occurred on maybe four separate occasions with greatly increased time between each occurrence. I'm thinking the issue has corrected itself but I realize it might reoccur tomorrow. I am careful not to completely top off the fuel tank, not sure if that helps but it's worth a shot. I might not let the dealer tinker with it unless it acts up again.

UPDATE: My cart now has 150 hours on it and the problem has not resurfaced. Therefore I did not take it back to the dealer again or unplug the O2 sensor or disconnect the charcoal canister (if it ain't broke, don't fix it). I am now convinced the issue was water/condensation in the fuel due to the cart had been in the dealer's showroom for an extended period of time. I think that would explain the issue as the problem seemed to lessen and eventually go away after having gone through several tanks of gas.

It might just be in my head but it seems my fuel mileage has increased tremendously after having "broken in" the cart. Initially I had to fill 'er up once per week. Now it seems to be more like once per month.

I am very happy with the purchase.

FloridaCart 05-15-2021 10:01 AM

Re: 2019 Onward Kohler Issues
 
Thanks for update Billy.... Did you get your cart from Potter motor's in Albany ?


All times are GMT -5. The time now is 03:31 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.