Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Gas Yamaha (https://www.buggiesgonewild.com/forumdisplay.php?f=17)
-   -   1982 G1 missing at WOT (https://www.buggiesgonewild.com/showthread.php?t=103092)

willie1981 02-20-2015 07:39 PM

1982 G1 missing at WOT
 
I have been rebuilding a 1982 G1 from the ground up for several months now and it is starting to come together finally. The engine has been rebuilt from top to bottom, bored .25 over, shaved the head 0.025, and purchased a stock air box. It seems to idle up and down constantly and misses bad at WOT. Any advice would be appreciated. Thanks..

1970buick 02-20-2015 08:34 PM

Re: 1982 G1 missing at WOT
 
HI, seeing as you did a full rebuild, I assume you rebuilt/cleaned the carb. Mine was doing the same thing and there was something in the main jet restricting fuel at wot

willie1981 02-20-2015 08:44 PM

Re: 1982 G1 missing at WOT
 
Yes, carb has been cleaned numerous times. Could the Jets need to be slightly larger from the boring and shaving of the head possibly? I pulled the plug and it appeared to be between a white and tan color.

Cvans 02-20-2015 08:50 PM

Re: 1982 G1 missing at WOT
 
It is possible that your jetted too lean. Check your spark plug. It should be coffee colored. If it is lighter or egg shell colored your too lean and need to get the problem resolved before the engine is damaged or seizes up. If it is dark or wet your running too rich or the plug is miss firing. If the plug is coffee colored try a new plug.

willie1981 02-20-2015 09:00 PM

Re: 1982 G1 missing at WOT
 
Thanks. The color does appear to be the color of an egg shell maybe slightly darker. I will get a pick of the plug in the a.m and get it posted. It seems to run smooth except at idle and WOT

chompy 02-21-2015 04:13 PM

Re: 1982 G1 missing at WOT
 
My experiences with the "82" is that they have a tendency to not run very well at WOT, unlike all other G1 2 strokes. The 82 has a lower compression and odd porting in the cylinder designed really for going slow on the course. Think about changing the top end if you want more speed.

willie1981 02-21-2015 08:40 PM

Re: 1982 G1 missing at WOT
 
That makes sense. I found a small air leak around the air box which fix the idle surging issue. Took the carburetor apart again and cleaned all of the jets. The engine idles and running so really smooth now except for wot. I am hearing get some noise in the top end. Is this normal for the 2-stroke? There was no slack in the rod or wrist pin bearings.

Cvans 02-21-2015 08:53 PM

Re: 1982 G1 missing at WOT
 
It's possible that your timing is advance a little too far and your hearing pre-ignition.
This could also account for the rough running at full throttle.

willie1981 02-21-2015 09:07 PM

Re: 1982 G1 missing at WOT
 
OK I will double check the timing. Just to verify, does turning the timing plate towards the front of the motor advance or retard the timing?

Cvans 02-21-2015 11:06 PM

Re: 1982 G1 missing at WOT
 
I would have to look at the service manual to tell you. I installed a diesel in my cart some time ago and can't remember how the timing is set.


All times are GMT -5. The time now is 12:25 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.