Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Gas EZGO (https://www.buggiesgonewild.com/forumdisplay.php?f=15)
-   -   295 intermittent spark (https://www.buggiesgonewild.com/showthread.php?t=180093)

Kenlhlp 10-12-2021 12:49 PM

295 intermittent spark
 
When I engage the starter I get one spark across the plugs, then nothing. Pulsar measures good according to the manual. Coil new and the Igniter.

Any ideas appreciated.

Thanks,
Ken

trig123 10-12-2021 01:41 PM

Re: 295 intermittent spark
 
Quote:

Originally Posted by Kenlhlp (Post 1857097)
When I engage the starter I get one spark across the plugs, then nothing. Pulsar measures good according to the manual. Coil new and the Igniter.

Any ideas appreciated.

Thanks,
Ken

Sounds like a bad ignitor. Did you buy a cheap one ?

crash12888 10-13-2021 06:56 AM

Re: 295 intermittent spark
 
Be sure to remove and clean ALL of your ground attatching points, wires and ground stud over by the solenoid as well, Ezgo has a tendency to corrode there and cause a spark loss.
But, like trig says, Interweb cart electronics are junk, check your grounds and reinstall your OEM parts, but if you have to buy anything, unfortunately, OEM is the way to a long running cart.

Cartmaster 10-13-2021 07:24 AM

Re: 295 intermittent spark
 
Also if you have disconnected the battery recently, Check you have it connected the right way (negative to ground ) easy mistake to make and can cause your symptoms.

Kenlhlp 10-13-2021 10:08 AM

Re: 295 intermittent spark
 
Thanks guys.

Note...I never use junk parts from China. Always OEM.

trig123 10-13-2021 12:10 PM

Re: 295 intermittent spark
 
Quote:

Originally Posted by Cartmaster (Post 1857242)
Also if you have disconnected the battery recently, Check you have it connected the right way (negative to ground ) easy mistake to make and can cause your symptoms.

What I have found when someone installs the battery incorrect it will spark one time just as you let off the pedal. I think his is sparking the one time when you first hit the pedal ? which normally is a bad ignitor.

trig123 10-13-2021 12:17 PM

Re: 295 intermittent spark
 
1 Attachment(s)
I also will mention to Kenlhlp that some dealers are now selling aftermarket ignitors.
The marking on an OEM ignitor is Kokusan Denki Made in Japan.
Check plastic connection where pulser coil plugs in good and also like crash12888 said the grounds. Wiggle the pulser connection while checking for fire.
I assume we are talking about the Pre-Mci engine also ? because the dealer I buy from no longer has the ignitor . Same with ezgo in Augusta

Cartmaster 10-14-2021 04:40 AM

Re: 295 intermittent spark
 
Quote:

Originally Posted by trig123 (Post 1857298)
What I have found when someone installs the battery incorrect it will spark one time just as you let off the pedal. I think his is sparking the one time when you first hit the pedal ? which normally is a bad ignitor.

Good catch Trig, I should have noticed that.

Kenlhlp 10-14-2021 01:00 PM

Re: 295 intermittent spark
 
Great info guys. I am in process of checking all the connections.

Kenlhlp 10-22-2021 01:43 PM

Re: 295 intermittent spark
 
Still having problems. Found the two pin pulsar plug was bad and eliminated it. I have replaced all the grounds and cleaned all connections. Rebuilt the original carburetor.

I have good spark now. It tries to start. Fires sporadically with the throttle at minimum. Eventually the engine starts. When running it has power, idles and accelerates fine. If I come to complete stop, then try going again the engine is back to sporadic firing, no go.

Just at a loss what could be wrong.


All times are GMT -5. The time now is 08:38 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.