Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Gas EZGO (https://www.buggiesgonewild.com/forumdisplay.php?f=15)
-   -   295 robin engine lack of power (https://www.buggiesgonewild.com/showthread.php?t=180269)

richieandtunacan 10-20-2021 01:48 PM

295 robin engine lack of power
 
i have ezgo with 295 robin engine. even with complete tune up, valve adjustment, and new carb it lacks power. timing is correct. coil is firing properly. and it has good compression. ANY IDEAS?

trig123 10-20-2021 02:26 PM

Re: 295 robin engine lack of power
 
Quote:

Originally Posted by richieandtunacan (Post 1858333)
i have ezgo with 295 robin engine. even with complete tune up, valve adjustment, and new carb it lacks power. timing is correct. coil is firing properly. and it has good compression. ANY IDEAS?

Driven clutch worn out maybe ? Also check to make sure its not overcharging.

crash12888 10-20-2021 02:27 PM

Re: 295 robin engine lack of power
 
Remove the drive belt and see how responsive it is without it.
Also, with it running, put your hand behind the exhaust outlet and see what kind of output you have, could be mud dobber nest in there.
If it's really restricted, try removing the muffler and try it.


All times are GMT -5. The time now is 07:47 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.