Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Electric Yamaha (https://www.buggiesgonewild.com/forumdisplay.php?f=18)
-   -   no action any where (https://www.buggiesgonewild.com/showthread.php?t=165469)

Papas 73Dart 06-18-2020 09:25 PM

no action any where
I am working on a 2007 Yamaha g29 (YRDE) and it has me stumped
originally the owner claimed to have seen smoke then the cart wouldn't start and he assumed it was the voltage reducer. He took it off and when he bought the replacement it wasn't exactly the same so he towed it to me.
I did the basics to insure the battery pack was fully charged and all the cable were cleaned.I have the manual and did the tests for cart will not operate in either direction no solenoid clicking.
of 16 tests #7 says to confirm reverse buzzer works so it does not ! on to test for reverse buzzer and step #4 says continuity good replace motor controller. just to be on the safe side i removed the motor controller from my 2007 G29 and tried the customers dead as a door nail. Reconnected mine and all was good.
So I ordered a new controller and solenoid and installed them today .
CRICKETS absolutely dead same as before. I have opened he wiring loom and checked for any burnt or broken wires and have found nothing and all the fuses and the tow/run switch is new and good.I haven't tried the new controller in my cart since the wife is golfing but I will later . I have done the step by step tests 1-16 in the manual and it says to replace the controller
it was brand new in an unopened box so i suspect there is something I have missed or the manual didn't show in the tests.I spoke to the service tech at the dealer and according to him I did it all correctly.
Any Ideas I'm Stumped ?

Papas 73Dart 06-25-2020 07:13 PM

Re: no action any where
I have tested every wire and have a fully chaRged battery pack 50.5 v the motor control,solenoid,tow run switch and charge recepticle Are all brand new. I have tested all the harness from the motor controll plug to back up alarm,forward reverse switch,foot pedal and the tps and there is continuity at every terminal. The only thing that gives no readings is the tps but it should not stop the solenoid from at least cycling when you turn on the the tow run switch.
i have also put the controller in another cart and played a round of golf no problems at least with the controller.
is it possible the contacts inside the 24 pin plug are bad and not making contact?

cgtech 06-25-2020 07:34 PM

Re: no action any where
1 Attachment(s)
Did you find a fuse that was a 3a fuse? And was it good? (Its the one that's most important in this situation). I understand that you have this diagram from the service manual, I only included it to illustrate that only the 3a fuse is important for you to get it running. Its usually near the motor controller. It provides power to controller pins 12 & 13, the ones that provide power to the controller logic board.

Papas 73Dart 06-25-2020 08:57 PM

Re: no action any where
I have tested that fuse and it is good . The main plug into the controller apoear good but if you wiggle it sometimes the back up alarm will work but sometimes it will stay on even when the switch is moved to forward. Also occasionally the solenoid will click like it is cycling but nothings happens forward or reverse.
I didnít get any ohm readings with the TPS Plugged in and my ohmmeter on the main plug wires are black,blue and orange. Probing those wires at the main plug while it was unplugged was supposed to give a1-150 ohms and the other pair were supposed to have 0-5000 ohms . I got nothing
A bad TPS should stop the solenoid from cycling when you energize the tow run switch or will it.
Fortunately all the parts i have replaced so far were in fact faulty but I seem no closer to getting a running cart

cgtech 06-26-2020 10:48 AM

Re: no action any where
2 Attachment(s)
It's not 0-5k ohm (an error in the manual they "are gonna fix in the next issue" forever). "Wiggling the plug" cant 'accidentally' provide B- to the reverse buzzer to activate it. I'd swear it has a bad harness.

Notice the difference of the illustration of the (0-5k ohm) sensor on the G19 vs the 0-5v hall effect sensor on YDRE.

Papas 73Dart 06-28-2020 02:00 PM

Re: no action any where
Today I removed the harness from the dead cart and I took the harness out of my running cart . Installed good harness in dead cart and still nothing and i reconnected to all inputs to do fair test.
since I am working outside I had to stop because of pouring rain . is there anything else that can cause cart to be absolutely dormant? I worry I may wear out the fasteners with all my install and removals

cgtech 06-28-2020 03:51 PM

Re: no action any where
Try it with the TPS disconnected, maybe its failed & drawing down the 5v circuit, and pissing everything off.

Papas 73Dart 06-28-2020 03:55 PM

Re: no action any where
I will give it a shot when it quits raining

Papas 73Dart 06-28-2020 07:00 PM

Re: no action any where
I got a small window of no rain so I went and disconnected the TPS but it made no difference
all the red yellow wires have battery voltage but it acts as though there is no grounds anywhere. Correct me if i'm wrong but the om;y ground to the controller is the A 2 connection from the bat neg.to controller and then to the A 2 terminal on the motor as a joint cable?? all the other grounds are from the controller to the various switches and sensors IE: main plug terminals 3,4,6,24.
these grounds are turned on by the controller?
all my attempts are with the motor wiring connected and i have no put the old solenoid back since when I ground the red black wire manually the solenoid clicks but noting else happens.
any other suggestions are more than welcome nut i am going to put the harness back on my other cart tomorrow

Papas 73Dart 06-29-2020 09:49 PM

Re: No Action Anywhere
I had to put my harness back in my cart today or my wife was going to kill me.
my cart works just fine . I used a 12 volt light and a car battery to make sure every wire going to a plug was capable of passing at least 12 volts and some current from the controller 24 pin plug to every plug and all worked so ther are no hidden breaks in the harness. When i reconnected the harness in dead cart the backup beeper keeps working(not in reverse) unless i wiggle the 24 pin connector plug. Then the solenoid keeps clicking like its trying to cycle but turn the key to run and no forward or reverse.So I don't know if this qualifies as progress or just another glitch. I even put the old solenoid on and it did the same thing


All times are GMT -5. The time now is 11:55 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.