Buggies Gone Wild Golf Cart Forum

Buggies Gone Wild Golf Cart Forum (https://www.buggiesgonewild.com/index.php)
-   Electric Club Car (https://www.buggiesgonewild.com/forumdisplay.php?f=13)
-   -   club car goes only half speed (https://www.buggiesgonewild.com/showthread.php?t=53319)

marinak 08-23-2011 11:02 AM

club car goes only half speed
 
What could cause this problem? Also were can I get wiring diagram to troubleshoot. Thanks

caokgafamily 08-23-2011 11:25 AM

Re: club car goes only half speed
 
I can see your a newbie like me. These guys are going to need alot more info, year, model, 48volt, 36 volt, orig owner? will it take full charge? how old are the batteries?
what is the half speed mph, uphill, on the flat, is the cart stock? stuff like that...

Steve

marinak 08-23-2011 12:14 PM

Re: club car goes only half speed
 
Thanks Steve for the newbie prima.

The cart is a 2002 48 volt model. The batteries are new installed fall of 2010. The batteries take a full charge. There are no hills all flat land. Up until last week it ran fine. Now it will go at best half speed. Any thoughts as to what I should check???


All times are GMT -5. The time now is 02:24 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.