View Single Post
Old 12-25-2019, 08:44 PM   #1
TestPoint
Not Yet Wild
 
Join Date: Jul 2010
Posts: 28
Default G16 electrical issues

I have been chasing random hard to start, will not crank, will not start for several months. Most of the time it cranks and starts just fine but occasionally it will not even acknowledge the gas pedal. Other times it cranks but will not start or starts and runs poorly . . . or just fine.

Ignition coil . . . replaced months ago due to complete failure. That was not the start of the current issues.

Fuel pump . . . this failed and pumped cylinder full of gas. Strange failure symptom but changed that. Changed oil of course.

New battery . . . no obvious problem but it was 5+ years old. No change.

Tested, repeatedly and carefully the go pedal micro switch. Never saw any sign of failure.

Replaced voltage regulator ($20 China part) since it controls the starter process. That improved the situation in that the starter more reliably spun the engine but still have issues.

Starter/Generator seems to be weak starting or is not charging or drawing too much current as the battery discharges.

Replaced starter/generator ($100 China part). Spins engine much better. Obviously part of the problem.

Generator is producing 12.2v with the engine running max rpm's. Batt reads 12.6v with engine off.

That appears to leave me with having to polarize the generator and/or replace the voltage regulator.

Dark got me and I quit for the evening.

Read about grounding the green regulation wire for voltage test or running the starter with a jumper cable to polarize it.

I guess green ground in the morning. Jumper run later.

Thoughts appreciated.
TestPoint is offline   Reply With Quote